Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Cloudbreak Installation error in Docker

Cloudbreak Installation error in Docker

New Contributor

I want to install Cloudbreak on Docker. I am following the steps which is mentioned on Docker sites .. But I am getting below error while intialising profile for Cloudbreak on 'cbd init' step..

docker@default:~/cloudbreak$ wget http://public-repo-1.hortonworks.com/HDP/cloudbreak/cloudbreak-deployer_1.0.0_Linux_x86_64.tgz Connecting to public-repo-1.hortonworks.com (52.85.245.96:80) cloudbreak-deployer_ 100% |*******************************| 2526k 0:00:00 ETA

docker@default:~/cloudbreak$ tar xvf cloudbreak-deployer_1.0.0_Linux_x86_64.tgz

LICENSE.txt NOTICE.txt VERSION README

cbd

docker@default:~/cloudbreak$ sudo cp cbd /usr/local/bin

docker@default:~/cloudbreak$ cbd init

* Dependency required, installing jq latest ...

* Dependency required, installing docker-compose latest ...

* Dependency required, installing aws latest ...

env: can't execute 'python': No such file or directory

docker@default:~/cloudbreak$

Even after setting path for Python and installing images of python on Docker , its getting stuck at "* Dependency required, installing aws latest ..." and continue to stuck at this point.. can anyone know whats exactly problem here ?

6 REPLIES 6

Re: Cloudbreak Installation error in Docker

Mentor

Please use the latest Cloudbreak release. 1.0 is old.

Re: Cloudbreak Installation error in Docker

New Contributor

I am using new also .. still getting same error.. I am Cloudbreak release 1.1.0

Re: Cloudbreak Installation error in Docker

Mentor

At the time of writing Cloudbreak is at version 1.2.3 http://sequenceiq.com/cloudbreak-docs/release-1.2.3/

Highlighted

Re: Cloudbreak Installation error in Docker

New Contributor

Thanks but still I am getting same error :

root@rambabu:~# cbd init * Dependency required, installing sed latest ... * Dependency required, installing jq latest ... * Dependency required, installing docker-compose latest ... * Dependency required, installing aws latest ... env: can't execute 'python': No such file or directory

Also I have tried that in sequenceid.. but its giving some weird error ... I am installing in docker-machine which is default in Oracle VM..

Re: Cloudbreak Installation error in Docker

New Contributor

@Rambabu Gupta

Which cloud provider are you using, and what OS? We provide prebuilt images for each of them: http://sequenceiq.com/cloudbreak-docs/latest/#pre-built-images

So for example if you want to use AWS, you can just start our AMI and latest cbd wil be installed and ready to use.

Re: Cloudbreak Installation error in Docker

New Contributor

Hi, I am using Oracle VM on my local window machine and Using docker-machine on Oracle VM.. but I could not able to install it.. I want the enviroment on my local window machine thats y I am using Oracle VM, Docket and Cloudbreak to work together

Don't have an account?
Coming from Hortonworks? Activate your account here