Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Cloudbreak + Knox + Proxy

Solved Go to solution
Highlighted

Cloudbreak + Knox + Proxy

Explorer

Hi,

I'm using Cloudbreak 2.7.1 and I'm in a locked down environment with proxy set up.

I was able to configure everything properly, cbd can talk to my cluster and the basic cluster was deployed successfully.

However, that's not the case when I enable Knox Gateway on a cloudbreak level. The whole installation fails.

I think it's a bug (knox is not ambari managed, so I guess it's installed in different way and it doesnt respect proxy env vars or similar) , which I don't know how to resolve.

This is currently a blocker for me.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Cloudbreak + Knox + Proxy

Expert Contributor

Hi @Jakub Igla,

Could you install a cluster without CB managed Knox and add Knox service via Ambari? If it solves your problem I suggest you should use Knox gateway this way.

View solution in original post

2 REPLIES 2
Highlighted

Re: Cloudbreak + Knox + Proxy

Expert Contributor

Hi @Jakub Igla,

Could you install a cluster without CB managed Knox and add Knox service via Ambari? If it solves your problem I suggest you should use Knox gateway this way.

View solution in original post

Highlighted

Re: Cloudbreak + Knox + Proxy

Explorer

Hi @mmolnar

I've deployed Knox via Ambari and it works as expected. Now I have Cloudbreak and the cluster 100% behind the proxy.

Don't have an account?
Coming from Hortonworks? Activate your account here