Support Questions
Find answers, ask questions, and share your expertise

Cloudbreak on Azure: Provisioning cluster with new MIT Kerberos KDC - running into errors




HDP 2.6, existing Vnet/subnet (with custom DNS server), availability sets, Kerberos with new MIT Kerberos KDC
Simple Ambari blueprint- tried and tested
Cloudbreak 1.16.5

After 12+ hours - provisioning did not complete.

Some errors:
Ambari component version: The cluster's current version could not be determined
Services say installation pending
Zookeeper shows restart required but when restart is attempted - service invalidate state error with message HOST_SVCCOMP_OP_IN_PROGRESS at INIT

Note: I was able to kerberize post cluster provisioning without issues in a separate instance.

Any insight is appreciated. Thanks.



Sorry for such a long response time. Kerberos support was in TP in Cloudbreak and it was completely refactored in version 2.2.

Our team would be very helpful if you could try to reproduce the issue in v2.2.

It is not listed in Marketplace but can be installed from an ARM template.

The Kerberos doc for Cloudbreak 2.2 is here.

One thing to note is as the UX of Cloudbreak is renewed completely, Availability set support is to be included in the yet to released Cloudbreak 2.3 version only.

Thank you for your support!



Sorry for the late response. Had a chance to try this out.

local version:2.2.0-96149cf
latest release:1.16.5

(1) UI looks great (thumbs up!)
(2) Ran into a bug - the "create cluster" button would not get enabled whatsoever :))
- with and without "enable Kerberos" checked
- template feature is missing
- and the SSH key was randomly showing in red or green if I tabbed through it randomly
- simple, tried and tested ambari blueprint
- existing vnet, subnet, nsg
I duodecuple-checked my entries to ensure accuracy and completeness but to no avail. 🙂

Appreciate the effort that has gone into this version. Look forward to fixes and to trying out test KDC and existing KDC.


Our team appreciate your effort in trying out the feature, however I cannot understand nor reproduce the errors completely. Could you please open a ticket in Cloudbreak github repo with the steps?

Also fyi, there will be further enhancements in Kerberos feature coming in v2.4.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.