Support Questions
Find answers, ask questions, and share your expertise

Cloudbreak on Azure - failed to register Microsoft.Compute provider

I tried to deploy Cloudbreak 1.6.3 on Microsoft Azure. I deployed the cbDeployer VM and created an Active Directory user. In step "Azure Application Setup with Cloudbreak Deployer", the ARM application creation fails with the error:

info:    Executing command provider register
+ Registering provider Microsoft.Compute with subscription 5227c284-8df6-4b91-8e87-2fdbdb8978aa
error:   Namespace Microsoft.Compute Registration took too long to complete
info:    Error information has been recorded to /root/.azure/azure.err
error:   provider register command failed

After this, if I try to log in to the Cloudbreak GUI, I get a 404 error. Why is it failing?


Expert Contributor


I assume it's a new subscription so you have to register to the different providers to use them. You can use the azure cli for that or follow the documentation here: and try again.

Thanks, I see in the GUI that the provider is stuck in "Registering". I tried to unregister and register again, but it does not seem to finish?