Support Questions
Find answers, ask questions, and share your expertise

Cloudbreak private image not found on Openstack

Hi,

I want to deploy HDP with a private image but i have an error message : Image not found.

With a public image, it's working.

I created the os-images.yml with the following content :

openstack:
  BHS3: test-cdb

I checked that the image existed via the glance api and my tenant name is OK.

Thanks for your help,

Best regards,

23 REPLIES 23

@bbihari, attached the information of the 2 images, but i don't see any difference, except the visibility and the owner.;

do you think that the tenant name is correctly use by Cloudbreak ?

47444-capture-decran-2018-01-04-10-18-27.png

Contributor

Could you try to make your image public?

In your OpenStack credential which version of keystone (v2, v3) did you use?

@bbihari, it's not possible because i use the OVH Public cloud.

The version of keystone is v2 but i also tested the V3.

Contributor
@Mathieu Perochon

, please double check the tenant name in you credential.

Which version of OpenStack do you using? Please check the version in the list of supported OpenStack versions.

@bbihari

I use the full juno version and my tenant name is correct.

To exclude this possibility, is it well equivalent to Project name ?

Contributor

@Mathieu Perochon, no, project name is in Keystone v3, tenant is in Keystone v2, I don't think you can mix these two concept.

@bbihari, Ok, i checked my tenant name with my Openstack RC file v2 and it is correct.

@bbihari, i just tested on newton version and it's working but i have a lot of region on juno version.

Contributor
@Mathieu Perochon

, if you have a contact to a Hortonworks Solution Engineer, please contact him, and we will be able to look into your issue more deeply

@bbihari, I found a quicly solution on OpenStack Juno.

You must upload your image by Glance API using the Glance CLI.

This temporary solution is not enough, but few unlock a few people