Support Questions
Find answers, ask questions, and share your expertise

Cloudera Hadoop datanode not starting

New Contributor

I have installed CDH 5 in single node Ubuntu 14.04 LTS machine in pseudo distributed mode using the cloudera guide : Previously I had installed Mvr1. It was running fine. Then i decided to migrate to YARN. I used the uninstallation process of Mvr1 mentioned in the tutorial then continued with the YARN installation. But after I start all services,I see all services starting except my datanode. Even when I am checking the status of datanode in the web console it shows no of live nodes as zero. I have tried to start the datanode separately with the service command but it shows "Failed to start Hadoop datanode. Return value: 1". I have tried formatting the namenode and restarting all services but with no help. Can you help me understand what has gone wrong?


Re: Cloudera Hadoop datanode not starting

Can you post the status message of the datanode

Re: Cloudera Hadoop datanode not starting


You need to check the logs: