Support Questions

Find answers, ask questions, and share your expertise

Cloudera Manager 6.3 OpenJDK 11

Explorer

CM 6.3 officially supports openjdk 11, but I think there is a bug in the init scrip when it tries to find the java version, it fails.  Looking at the script /opt/cloudera/cm/bin/cm-server, it looks like it tries to find the Java version, but it doesn't have a search path for openjdk 11.

3 REPLIES 3

Super Guru

@knasher,

 

Thanks for reporting this.  Can you share a bit more regarding what you were doing, where the failure occurred, and some of how you arrived at your possible cause.  I'm about to take a look at this on CentOS... what OS are you on and where is your jdk located?

Explorer
Hi, I am running Ubuntu Bionic, and I'm using openjdk-11-jdk-headless from
the default ubuntu repo. This puts java at
/usr/lib/jvm/java-11-openjdk-amd64. I first got the error when I installed
the cloudera-manager-daemons package, but I was able to work around this by
setting JAVA_HOME. However when I run the cloudera manager after this,
then it gives the same error even if JAVA_HOME is set. The error is just
saying that java couldn't be found. Thanks

Super Guru

@knasher 

CM will try to locate the SDK but in this case, it may need to be told explicitly.

To configure JAVA_HOME for Cloudera Manager, add it to /etc/default/cloudera-scm-server

JAVA_HOME=/usr/lib/jvm/java-11-openjdk-amd64

 

After you have updated the file, restart Cloudera Manager with service cloudera-scm-server restart.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.