Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Cloudera Manager Installation failed

Cloudera Manager Installation failed

New Contributor

Unable to install CDH 5.3 using using cloudera-manager-installer.bin, error message is:

 

http://archive.cloudera.com/cm5/redhat/6/x86_64/cm/5/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"

 

I have tried setting up proxy, i am able to ping, i have also created  cloudera-manager.repo file, still no luck

 

Please help.

 

Thanks.

8 REPLIES 8

Re: Cloudera Manager Installation failed

Expert Contributor

Hi VikramGoyal

 

Can you do a yum update or can you browse with like lynx or links?

 

I had similiar issues and found either I have to define gateway interface, environment, or proxy.   

 

Also if you haven't yet I put all my proxy settings in /etc/environment then just issue the

 

# . /etc/environment

 

or

 

# source /etc/environment

 

and test connectivity.  Hope it helps.

 

Let us know how it goes.

Re: Cloudera Manager Installation failed

New Contributor

Hello,

 

Thanks for your response, i tried defining proxy in bash and in /etc/.yum.conf but still no success.

 

How do i pull all my proxy settings to /etc/environment, please let me know.

 

Tried doing multiple things like iptables, etc but unable to get through and always end up in below error.

 

This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Repository 'local' is missing name in configuration, using id
http://archive.cloudera.com/cdh5/redhat/6/x86_64/cdh/5/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: cloudera-cdh5. Please verify its path and try again

 

Thanks,

Vikram

Re: Cloudera Manager Installation failed

Super Collaborator

For the CM and agent setup, following the "Path B" documentation from our installation guide, you can set up a local repo within your network to get CM and the Agents & Daemons packages deployed to your cluster nodes.  You can then use the proxy configuration within CM to set up your proxy for accessing the parcels.

 

To set up the CM repo, you can use the repo-as-tarball.  It can be downloaded from here: 

 

http://archive.cloudera.com/cm5/repo-as-tarball

 

You can set up a basic Apache HTTPD to serve the repo from within your network (just unpack into or sym-link from your web server root).   It is not necessary to run any kind of build repo commands over this, the path is ready to have you configure the URL and path for your yum repo configuration file.  This is documented here: http://www.cloudera.com/content/cloudera/en/documentation/core/latest/topics/cm_ig_create_local_pack...

 

Otherwise if you do not want to set up an internal repo, you would have to work on enabling the proxy for your yum command (with discussion like this being how to do this). 

 

http://www.cyberciti.biz/faq/centos-redhat-fedora-linux-using-yum-with-a-proxy-server/

 

 

Re: Cloudera Manager Installation failed

New Contributor

 

I was able to install it using the correct proxy configuration

 

Cluster Installation

 
Detecting CDH versions on all hosts

All hosts have the same CDH version.


  • The following host(s) are running CDH 5.3.2: xxx.abc.com

------------------------------------------------------------------------------

Now, when i move to the next page after pressing Continue, i get below Error without any error message:

Please help.

 

ClouderaSS.png

Re: Cloudera Manager Installation failed

Super Collaborator

Ok thats is truely a useless error message anounce, indeed.

 

Did you session happen to timeout while you attempted to resolve the issue?

 

If you click on the "Cloudera Manager" logo to skip the wizard, is there anything showing in the "All Recent Commands" link within the CM UI?

 

Home_-_Cloudera_Manager.png

Re: Cloudera Manager Installation failed

New Contributor

 

I restarted cloudera scm server using "sudo service cloudera-scm-server restart" command it resolved this issue.

 

Now i am at cluster setup stage and receiving below error:

 

Error1.png

 

 

Error2.png

Re: Cloudera Manager Installation failed

Your port is in use. Check what's running on that port.

If you did a packages install, make sure you didn't install the init scripts packages like hadoop-hdfs-namenode, as this will cause a conflicting NameNode process to start.

You can run the host inspector (on the hosts tab) to verify that these kinds of init scripts aren't installed by accident.

Re: Cloudera Manager Installation failed

New Contributor

 

I was able to kill the jobs and using that port and there after i successfully started all the services (HDFS, HIVE, OOZIE etc.).

 

Now i am at hue and it's showing below configuration error:

 

Error3.png