Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Cloudera Manager Installation

Cloudera Manager Installation

Explorer

Hello,

 

I am trying to install Cloudera Manager using Standard verion for distributed environment. I have created one main server named Cloudera-Server & i have created 3 hosts named host1, host2, host3.

I have installed Cloudera server successfully on my main server. Now i want to add a new host on this server.

 

If i am using cloudera repositories then host successfully installed but if I am using custom repositories for installing host , it gives error.

I want to know why this error came in custom repositories case. When we are using their repositories then also it takes libpython 2.4 from somewhere. Please help me in this situation.

 

List of repositories is shown below:

 

:: noarch ::

 

 

[PARENTDIR]Parent Directory - 
[SND]bigtop-tomcat-6.0.35..>2013-08-28 13:067.2M 
[SND]bigtop-utils-0.4+300..>2013-08-28 13:057.4K 
[SND]bigtop-utils-0.6.0+7..>2013-08-28 13:067.9K 
[SND]flume-ng-1.3.0+159-1..>2013-08-28 13:0514M 
[SND]flume-ng-agent-1.3.0..>2013-08-28 13:065.7K 
[SND]flume-ng-doc-1.3.0+1..>2013-08-28 13:051.1M 
[SND]flume-ng-solr-0.9.3-..>2013-08-28 13:0540M 
[SND]hadoop-0.20-mapreduc..>2013-08-28 13:055.0K 
[SND]hadoop-0.20-mapreduc..>2013-08-28 13:055.6K 
[SND]hadoop-0.20-mapreduc..>2013-08-28 13:054.9K 
[SND]hadoop-0.20-mapreduc..>2013-08-28 13:055.0K 
[SND]hbase-solr-0.9.3-1.c..>2013-08-28 13:0697M 
[SND]hbase-solr-doc-0.9.3..>2013-08-28 13:068.8K 
[SND]hbase-solr-indexer-0..>2013-08-28 13:064.7K 
[SND]hcatalog-0.5.0+9-1.c..>2013-08-28 13:06398K 
[SND]hcatalog-server-0.5...>2013-08-28 13:054.8K 
[SND]hive-0.10.0+121-1.cd..>2013-08-28 13:0519M 
[SND]hive-hbase-0.10.0+12..>2013-08-28 13:052.4K 
[SND]hive-jdbc-0.10.0+134..>2013-08-28 13:059.5M 
[SND]hive-metastore-0.10...>2013-08-28 13:055.0K 
[SND]hive-server-0.10.0+1..>2013-08-28 13:054.9K 
[SND]hive-server2-0.10.0+..>2013-08-28 13:055.1K 
[SND]mahout-0.7+16-1.cdh4..>2013-08-28 13:0692M 
[SND]mahout-doc-0.7+16-1...>2013-08-28 13:06170K 
[SND]oozie-3.3.2+49-1.cdh..>2013-08-28 13:06179M 
[SND]oozie-client-3.3.2+4..>2013-08-28 13:053.6M 
[SND]pig-0.11.0+28-1.cdh4..>2013-08-28 13:0553M 
[SND]pig-udf-datafu-0.0.4..>2013-08-28 13:06455K 
[SND]search-0.9.3-1.cdh4...>2013-08-28 13:0699M 
[SND]sentry-1.1.0-1.cdh4...>2013-08-28 13:05390K 
[SND]solr-4.3.0+74-1.cdh4..>2013-08-28 13:0659M 
[SND]solr-doc-4.3.0+74-1...>2013-08-28 13:0532M 
[SND]solr-mapreduce-0.9.3..>2013-08-28 13:0645M 
[SND]solr-server-4.3.0+74..>2013-08-28 13:064.4K 
[SND]sqoop-1.4.3+34-1.cdh..>2013-08-28 13:065.8M 
[SND]sqoop-metastore-1.4...>2013-08-28 13:054.9K 
[SND]sqoop2-1.99.1+115-1...>2013-08-28 13:057.1M 
[SND]sqoop2-client-1.99.1..>2013-08-28 13:056.7M 
[SND]sqoop2-server-1.99.1..>2013-08-28 13:054.6K 
[SND]webhcat-0.5.0+9-1.cd..>2013-08-28 13:0655M 
[SND]webhcat-server-0.5.0..>2013-08-28 13:054.8K 
[SND]whirr-0.8.2+10-1.cdh..>2013-08-28 13:0531M 
[SND]zookeeper-3.4.5+19-1..>2013-08-28 13:053.7M 
[SND]zookeeper-server-3.4..>2013-08-28 13:064.9K 

 

 

:: x86_64 ::

 

Parent Directory - 
[SND]bigtop-jsvc-1.0.10-1..>2013-08-28 13:0727K 
[SND]bigtop-jsvc-debuginf..>2013-08-28 13:0755K 
[SND]cloudera-manager-age..>2013-08-28 13:073.6M 
[SND]cloudera-manager-age..>2013-08-29 11:484.6M 
[SND]cloudera-manager-dae..>2013-08-28 13:07135M 
[SND]cloudera-manager-ser..>2013-08-28 13:077.7K 
[SND]cloudera-manager-ser..>2013-08-28 13:069.4K 
[SND]enterprise-debuginfo..>2013-08-28 13:07656K 
[SND]hadoop-0.20-conf-pse..>2013-08-28 13:077.4K 
[SND]hadoop-0.20-mapreduc..>2013-08-28 13:0725M 
[SND]hadoop-2.0.0+1357-1...>2013-08-28 13:0716M 
[SND]hadoop-client-2.0.0+..>2013-08-28 13:0615K 
[SND]hadoop-conf-pseudo-2..>2013-08-28 13:078.0K 
[SND]hadoop-debuginfo-2.0..>2013-08-28 13:071.5M 
[SND]hadoop-doc-2.0.0+135..>2013-08-28 13:066.3M 
[SND]hadoop-hdfs-2.0.0+13..>2013-08-28 13:0612M 
[SND]hadoop-hdfs-datanode..>2013-08-28 13:074.9K 
[SND]hadoop-hdfs-fuse-2.0..>2013-08-28 13:0721K 
[SND]hadoop-hdfs-journaln..>2013-08-28 13:064.8K 
[SND]hadoop-hdfs-namenode..>2013-08-28 13:064.9K 
[SND]hadoop-hdfs-secondar..>2013-08-28 13:064.9K 
[SND]hadoop-hdfs-zkfc-2.0..>2013-08-28 13:075.0K 
[SND]hadoop-httpfs-2.0.0+..>2013-08-28 13:0717M 
[SND]hadoop-libhdfs-2.0.0..>2013-08-28 13:0727K 
[SND]hadoop-mapreduce-2.0..>2013-08-28 13:0610M 
[SND]hadoop-mapreduce-his..>2013-08-28 13:074.9K 
[SND]hadoop-yarn-2.0.0+13..>2013-08-28 13:078.4M 
[SND]hadoop-yarn-nodemana..>2013-08-28 13:064.9K 
[SND]hadoop-yarn-proxyser..>2013-08-28 13:064.7K 
[SND]hadoop-yarn-resource..>2013-08-28 13:074.8K 
[SND]hbase-0.94.6+96-1.cd..>2013-08-28 13:0637M 
[SND]hbase-doc-0.94.6+96-..>2013-08-28 13:079.4M 
[SND]hbase-master-0.94.6+..>2013-08-28 13:074.6K 
[SND]hbase-regionserver-0..>2013-08-28 13:076.8K 
[SND]hbase-rest-0.94.6+96..>2013-08-28 13:074.5K 
[SND]hbase-thrift-0.94.6+..>2013-08-28 13:075.1K 
[SND]hue-2.3.0+136-1.cdh4..>2013-08-28 13:072.7K 
[SND]hue-2.3.0.1-1.cdh4.3..>2013-08-28 13:062.3K 
[SND]hue-about-2.3.0+136-..>2013-08-28 13:0622K 
[SND]hue-beeswax-2.3.0+13..>2013-08-28 13:07667K 
[SND]hue-common-2.3.0+136..>2013-08-28 13:0732M 
[SND]hue-filebrowser-2.3...>2013-08-28 13:0695K 
[SND]hue-help-2.3.0+136-1..>2013-08-28 13:0714K 
[SND]hue-impala-2.3.0+136..>2013-08-28 13:0675K 
[SND]hue-jobbrowser-2.3.0..>2013-08-28 13:0786K 
[SND]hue-jobsub-2.3.0+136..>2013-08-28 13:06223K 
[SND]hue-metastore-2.3.0+..>2013-08-28 13:0738K 
[SND]hue-oozie-2.3.0+136-..>2013-08-28 13:07495K 
[SND]hue-pig-2.3.0+136-1...>2013-08-28 13:07339K 
[SND]hue-plugins-2.3.0+13..>2013-08-28 13:062.1M 
[SND]hue-proxy-2.3.0+136-..>2013-08-28 13:0711K 
[SND]hue-search-2.3.0.1-1..>2013-08-28 13:0793K 
[SND]hue-server-2.3.0+136..>2013-08-28 13:074.4K 
[SND]hue-shell-2.3.0+136-..>2013-08-28 13:0748K 
[SND]hue-useradmin-2.3.0+..>2013-08-28 13:0782K 
[SND]impala-1.1-1.p0.6.el..>2013-08-28 13:07102M 
[SND]impala-debuginfo-1.1..>2013-08-28 13:0772M 
[SND]impala-server-1.1-1...>2013-08-28 13:064.3K 
[SND]impala-shell-1.1-1.p..>2013-08-28 13:06649K 
[SND]impala-state-store-1..>2013-08-28 13:064.4K 
[SND]jdk-6u31-linux-amd64..>2013-08-28 13:0768M 

 

 

An error occured during installation in cloudera manager agent on host1.

 

1 REPLY 1
Highlighted

Re: Cloudera Manager Installation

Expert Contributor

Hi Radius,

 

Commonly this error:

 

   Requires: libpython2.4.so.1.0()(64bit)

 

is seen if you are attempting to install a RHEL5.x (-el5) package on a RHEL6.x (-el6) system.

 

It looks like you mirrored the RHEL 5 package for the 4.6.3 cloudera-manager-agent in your repo:

 

http://192.168.1.147/cloudera/cdh/6/RPMS/x86_64/cloudera-manager-agent-4.6.0-1.cm460.p0.140.x86_64.r...

 

as the filesize matches the one we have in our archive [http://archive.cloudera.com/cm4/redhat/5/x86_64/cm/4.6.3/RPMS/x86_64/].

 

The other agent you have in your repo (http://192.168.1.147/cloudera/cdh/6/RPMS/x86_64/cloudera-manager-agent-4.6.0-1.cm460.p0.140.x86_64.r... may be the right architecture, but is for an older version and thus is not being sourced.

 

Please retry adding the right agent package (and confirm that all the others are from the correct archive repo path for your architecture) and reattempt. Let us know how you fare!

 

Best,