Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here. Want to know more about what has changed? Check out the Community News blog.

Cloudera ODBC Driver for Apache Hive - SSL_connect: wrong version number

Cloudera ODBC Driver for Apache Hive - SSL_connect: wrong version number

New Contributor

I'm attempting to use Cloudera's ODBC Driver for Apache Hive Data Source and I'm getting the message SSL_connect: wrong version number.  The ODBC Driver for Impala is working without issue and cannot find what the message SSL_connect: wrong version number is indicating.  

 

Interested in hearing if anyone has encountered this issue.  Thanks.

1 REPLY 1
Highlighted

Re: Cloudera ODBC Driver for Apache Hive - SSL_connect: wrong version number

Master Guru
What is the output of the below command, run against your SSL-enabled HS2 host and port?

openssl s_client -connect host:port

Generally speaking, the error seems to suggest that the client SSL library got a version of SSL/TLS back from the server that it does not support. The above command will at least help confirm what that server version was, and you may also compare it with the host:port of Impala (which as you say, does connect successfully).

P.s. Worth checking if your HS2 is actually SSL enabled or not. If it is not, disable any SSL properties on the ODBC end.