Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Cloudera Quickstart VM 5.5 failed to boot on VirtualBox 5.0.14

Cloudera Quickstart VM 5.5 failed to boot on VirtualBox 5.0.14

New Contributor

 

I'm new to Hadoop development. My environment is primarily Windows-based. After days of trials-and-errors, I was finally able to get Hadoop compiled without errors and got it up and running. But, with so many other Linux-based components in Hadoop ecosystem I don't want to be distracted further so I decided to try Cloudera QuickStart.

 

I followed these two YouTube TOIs:

 

Virtual Box and Cloudera Quickstart VM Installation Tutorial   https://www.youtube.com/watch?v=BeCtjd86YXo

Installing Cloudera VM on VirtualBox on Windows    https://www.youtube.com/watch?v=L0lPPC5qeyU

 

But, not sure why it was so challenging for me?! I just couldn't bring up Cloudera CDH 5.5 on VirtualBox 5.0.14 on my Windows 7 workstation (64-bit). My desktop is a LENOVO 30AGS01Y00 w/ 1 Intel64 CPU, 16GB RAM and 1TB of HDD. The detail OS version: Windows 6.1.7601 Service Pack 1 Build 7601.

 

 

After installing VirtualBox and unzip Cloudera QuickStart VM 5.5, I created my VM with Red Hat (64-bit), Memory Size: 8,192MB and the "Use an existing virtual hard disk file" option to point to the vmdk file of the Cloudera quickstart for virtual box file. After the VM was created I adjusted its settings, as recommended, such as "Shared Clipboard", "DragnDrop", "Boot Order" (leave Hard Disk only).

 

The chipset setting was PIIX3 by default. It made no difference when I tried both PIIX3 and ICH9.

I left Processor as 1 CPU because my desktop has only 1 physical CPU even though its VT-x and physical HyperThreading were enabled. Nested Paging was also enabled.

 

The Storage of the Cloudera VM was created with SATA and Type: AHCI. The rest of settings remained no change (as default).

 

When I tried to boot the VM my VM screen looked exactly the same as depicted in this question:

Virtual machine “Cloudera quick start” not booting Virtual machine "Cloudera quick start" not booting

 

I've been goolging this issues for about a week. The above question is the closest case I could find on the web. I tried a variety of VM settings but no luck. Not sure what the root cause is.

 

I tried to fall back to Cloudera QuickStart VM 5.4.2. No luck either. Your advice is highly appreciated!!

 

I have the logs available. Some key events in VBox and VboxHardening logs were excerpted as follows:

 

Vbox.log:

00:00:02.535619 VMSetError: F:\tinderbox\win-5.0\src\VBox\Storage\VD.cpp(6410) int __cdecl VDOpen(struct VBOXHDD *,const char *,const char *,unsigned int,struct VDINTERFACE *); rc=VERR_NOT_SUPPORTED * Note: I don't know what F: drive is. There is no F: drive on my desktop.

 

00:00:02.520998 AIOMgr: Endpoint for file 'C:\CDH_5.4.2\cloudera-quickstart-vm-5.4.2-0-virtualbox-disk1.vmdk' (flags 000c0781) created successfully

 

00:00:02.535626 VMSetError: VD: error VERR_NOT_SUPPORTED opening image file 'C:\CDH_5.4.2\cloudera-quickstart-vm-5.4.2-0-virtualbox-disk1.vmdk'

00:00:02.567924 AIOMgr: Preparing flush failed with VERR_NOT_SUPPORTED, disabling async flushes

 

VBoxHardening.log:

62a4.318: NtOpenDirectoryObject failed on \Driver: 0xc0000022

 

By the way, after days of blindly trials and errors, I followed someone's advice and was able to "Import" the .ovf file and get the QuickStart VM up and running in the VirtualBox. It's even more convenient. But still, why can't CDH 5.5 boot from VirtualBox 5.0.14? It'd be good to know what I may be missing by learning the root cause.

 

Thanks!

 

 

-jsung8

12 REPLIES 12

Re: Cloudera Quickstart VM 5.5 failed to boot on VirtualBox 5.0.14

New Contributor

Can you please provide specific instructions on "importing" the .ovf file? I'm facing the same problems that you were.

Re: Cloudera Quickstart VM 5.5 failed to boot on VirtualBox 5.0.14

New Contributor

To import the QuickStart VM (.ovf or .ova),

1. Select File and then "Import Appliance (Ctrl I) " in VirtualBox.

2. Browse to find your .ovf (or .ova) and click Next

3. You may leave everything default and click Import.

 

Via this "Import Appliance" method, I was able to bring up QuickStart 5.4.2 and 5.5.0, on VirtualBox 5.0.14 on my Windows 7 desktop. It took about 4-5 minutes to finish the boot up process.

 

Re: Cloudera Quickstart VM 5.5 failed to boot on VirtualBox 5.0.14

New Contributor

I'm having issues with the Clouder QuickStart VM on VBox as well. I have pulled in both 5.5 and 5.7 on both my Mac OS X two month old machine and my PC which is a Server. I get the same error 

init: prefdm main porcess ended

init: prefdm respawning too fast, stopped

 

I've been searching if clues for the past two days. I have other VMs that are working so I know it's not that. Would love to here if anyone knows what would get this working as I have a class I'm starting in a week. 

 

Re: Cloudera Quickstart VM 5.5 failed to boot on VirtualBox 5.0.14

Community Manager

I'm sorry to see you are having issues. Have you looked over our Community Knowledge article on how to start a Cloudera Quickstart VM? Otherwise, I can check with @Sean to see if he has a suggestion. 



Cy Jervis, Community Manager

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:
Community Guidelines
How to use the forum

Re: Cloudera Quickstart VM 5.5 failed to boot on VirtualBox 5.0.14

New Contributor
Thanks for the response, this has been quite a process but after two days of pain I got it to work. We live in the hills so I think the download was not coming in clean.

Re: Cloudera Quickstart VM 5.5 failed to boot on VirtualBox 5.0.14

Explorer

Hi, I got exact same problem with yours, "prefdm respawning too fast stopped" when booting up QuickStartCHD5.7, can you please tell me how did you solve the problem? Do you mean you are able to boot into the CentOS after download another the Virturl box Image(QuickStartCHD5.7)?


@LizDiamond wrote:
Thanks for the response, this has been quite a process but after two days of pain I got it to work. We live in the hills so I think the download was not coming in clean.

 

Re: Cloudera Quickstart VM 5.5 failed to boot on VirtualBox 5.0.14

Explorer
Hi, I got exact same problem with yours, "prefdm respawning too fast stopped" when booting up QuickStartCHD5.7, can you please tell me how did you solve the problem? Do you mean you are able to boot into the CentOS after download another the Virturl box Image(QuickStartCHD5.7)?
Highlighted

Re: Cloudera Quickstart VM 5.5 failed to boot on VirtualBox 5.0.14

Explorer
I have to switch to VMWare image(cloudera-quickstart-vm-5.7.0-0-vmware), and run the VM with VMWare Player, it's able to be boot up now. :)

Re: Cloudera Quickstart VM 5.5 failed to boot on VirtualBox 5.0.14

New Contributor

Was this issue resolved after another download  or did you make any config changes ?

Don't have an account?
Coming from Hortonworks? Activate your account here