Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 07-04-2019 06:19 PM - edited 07-04-2019 06:47 PM
# The database type
# Currently 'mysql', 'postgresql' and 'oracle' are valid databases.
com.cloudera.cmf.db.type=mysql
How can that be changed to postgres. I tried so many things and now out of options.
I am doing a POC and at first started the regular installation bu installing agent,server.daemons and bringing up CM server without a DB and then unstalled all retried using the cloudera-manager-installer.bin . After a day of searching i cannot get the installtion to complete.
The embedded database does not install with the below error
$$$$sudo cat /var/log/cloudera-manager-installer/7.start-cloudera-scm-server-db.log
Job for cloudera-scm-server-db.service failed because the control process exited with error code. See "systemctl status cloudera-scm-server-db.service" and "journalctl -xe" for details.
$$$$ systemctl status cloudera-scm-server-db.service
● cloudera-scm-server-db.service - LSB: Cloudera SCM Server's Embedded DB
Loaded: loaded (/etc/rc.d/init.d/cloudera-scm-server-db; bad; vendor preset: disabled)
Active: failed (Result: exit-code) since Thu 2019-07-04 21:09:39 EDT; 6min ago
Docs: man:systemd-sysv-generator(8)
Warning: cloudera-scm-server-db.service changed on disk. Run 'systemctl daemon-reload' to reload units.
## Tried systemctl daemon-reload many times still no luck and then reran installer
@Harsh J , @lhebert any thoughts here.
Created 07-05-2019 08:21 AM
$ sudo tail -100 /var/log/cloudera-scm-server/db.log
FATAL: could not create lock file "/var/run/postgresql/.s.PGSQL.7432.lock": No such file or directory
$ sudo mkdir /var/run/postgresql
$ sudo chown -R postgres:postgres /var/run/postgresql
Once i did this it fixed the problem.
Created 07-04-2019 07:17 PM
Created on 07-04-2019 07:31 PM - edited 07-04-2019 07:34 PM
Still no luck.
I dont know why it says mysql. ?? how is this generated and from where ?
$ sudo cat /etc/cloudera-scm-server/db.properties.20190704-222918
# Copyright (c) 2012 Cloudera, Inc. All rights reserved.
#
# This file describes the database connection.
#
# The database type
# Currently 'mysql', 'postgresql' and 'oracle' are valid databases.
com.cloudera.cmf.db.type=mysql
# The database host
# If a non standard port is needed, use 'hostname:port'
#com.cloudera.cmf.db.host=localhost
# The database name
#com.cloudera.cmf.db.name=cmf
# The database user
#com.cloudera.cmf.db.user=cmf
# The database user's password
#com.cloudera.cmf.db.password=
# The db setup type
# After fresh install it is set to INIT
# and will be changed post config.
# If scm-server uses Embedded DB then it is set to EMBEDDED
# If scm-server uses External DB then it is set to EXTERNAL
com.cloudera.cmf.db.setupType=INIT
And same error
$ sudo cat /var/log/cloudera-manager-installer/7.start-cloudera-scm-server-db.log
Job for cloudera-scm-server-db.service failed because the control process exited with error code. See "systemctl status cloudera-scm-server-db.service" and "journalctl -xe" for details.
$ sudo systemctl status cloudera-scm-server-db.service
● cloudera-scm-server-db.service - LSB: Cloudera SCM Server's Embedded DB
Loaded: loaded (/etc/rc.d/init.d/cloudera-scm-server-db; bad; vendor preset: disabled)
Active: failed (Result: exit-code) since Thu 2019-07-04 22:29:20 EDT; 4min 22s ago
Docs: man:systemd-sysv-generator(8)
Jul 04 22:29:19 itlenscms01 cloudera-scm-server-db[2984]: Creating SCM configuration file: /etc/cloudera-scm-server/db.properties
Jul 04 22:29:20 itlenscms01 cloudera-scm-server-db[2984]: waiting for server to start.... stopped waiting
Jul 04 22:29:20 itlenscms01 cloudera-scm-server-db[2984]: pg_ctl: could not start server
Jul 04 22:29:20 itlenscms01 cloudera-scm-server-db[2984]: Examine the log output.
Jul 04 22:29:20 itlenscms01 cloudera-scm-server-db[2984]: Could not start database server, giving up
Jul 04 22:29:20 itlenscms01 runuser[2997]: pam_unix(runuser:session): session closed for user cloudera-scm
Jul 04 22:29:20 itlenscms01 systemd[1]: cloudera-scm-server-db.service: control process exited, code=exited status=1
Jul 04 22:29:20 itlenscms01 systemd[1]: Failed to start LSB: Cloudera SCM Server's Embedded DB.
Jul 04 22:29:20 itlenscms01 systemd[1]: Unit cloudera-scm-server-db.service entered failed state.
Jul 04 22:29:20 itlenscms01 systemd[1]: cloudera-scm-server-db.service failed.
Warning: cloudera-scm-server-db.service changed on disk. Run 'systemctl daemon-reload' to reload units.
Created 07-04-2019 07:41 PM
Any idea what is mojosetup. Is it relevant here
Jul 04 22:31:14 itlenscms01 mojosetup[2720]: FATAL: Installation failed.
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Cleaning up half-finished installation...
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleted '/opt/cloudera/installer/uninstall-cloudera-manager.sh'
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleted '/opt/cloudera/installer/packages/ubuntu-xenial/cloudera-manager-repository_6.2.0_all.deb'
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleted '/opt/cloudera/installer/packages/ubuntu-xenial'
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleted '/opt/cloudera/installer/packages/ubuntu-bionic/cloudera-manager-repository_6.2.0_all.deb'
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleted '/opt/cloudera/installer/packages/ubuntu-bionic'
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleted '/opt/cloudera/installer/packages/sles12/cloudera-manager-repository-6.2.0-1.noarch.rpm'
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleted '/opt/cloudera/installer/packages/sles12'
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleted '/opt/cloudera/installer/packages/redhat7/cloudera-manager-repository-6.2.0-1.noarch.rpm'
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleted '/opt/cloudera/installer/packages/redhat7'
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleted '/opt/cloudera/installer/packages/redhat6/cloudera-manager-repository-6.2.0-1.noarch.rpm'
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleted '/opt/cloudera/installer/packages/redhat6'
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleted '/opt/cloudera/installer/packages/debian-jessie/cloudera-manager-repository_6.2.0_all.deb'
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleted '/opt/cloudera/installer/packages/debian-jessie'
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleted '/opt/cloudera/installer/packages'
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleting '/opt/cloudera/installer/.mojosetup/tmp/rollbacks' failed!
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleting '/opt/cloudera/installer/.mojosetup/tmp' failed!
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: Deleting '/opt/cloudera/installer/.mojosetup' failed!
Jul 04 22:31:16 itlenscms01 mojosetup[2720]: MojoSetup shutting down...
Created 07-04-2019 07:44 PM
If itry to uninstall i get this and it wont allow me to re-install . so i rename that file to allow for new installation.
sudo ./uninstall-cloudera-manager.sh
./uninstall-cloudera-manager.sh: line 2: /opt/cloudera/installer/.mojosetup/mojosetup: No such file or directory
Created 07-05-2019 08:21 AM
$ sudo tail -100 /var/log/cloudera-scm-server/db.log
FATAL: could not create lock file "/var/run/postgresql/.s.PGSQL.7432.lock": No such file or directory
$ sudo mkdir /var/run/postgresql
$ sudo chown -R postgres:postgres /var/run/postgresql
Once i did this it fixed the problem.
Created on 11-19-2019 06:23 PM - edited 11-19-2019 06:28 PM
It happened to me when I was installing cloudera 6.3.1,
What solved to me was:
1. run:
sed -i 's/SELINUX=enforcing/SELINUX=permissive/' /etc/selinux/config
2. config /etc/hosts: (just an exemple, set the host of all machines)
hostnamectl set-hostname master1.hadoop-test.com
echo "10.99.0.175 master1.hadoop-test.com master1" >> /etc/hosts
sed -i 's/\r//' /etc/hosts
echo "HOSTNAME=master1.hadoop-test.com" >> /etc/sysconfig/network
3.
reboot
then:
4.
wget <a href="https://archive.cloudera.com/cm6/6.3.1/cloudera-manager-installer.bin" target="_blank">https://archive.cloudera.com/cm6/6.3.1/cloudera-manager-installer.bin</a>
5.
chmod u+x cloudera-manager-installer.bin
6.
./cloudera-manager-installer.bin