Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Configuring NiFi Site to Site protocol for AWS nodes with no public ip

avatar

I have a Nifi cluster setup with 2 nodes in AWS EC2. One Nifi node has a public ip and 2nd one is on vpc. My cluster is up and running and I can see both my nodes from nifi public instance.

I want to add a remote process group pointing to same instance for load balancing. When I add a remote process group with same address as public server, it fails to communicate to node.

I have left nifi.remote.input.host as blank. Should I populate it with public ip address of server or private ip address of server ?

Thanks for any help.

1 ACCEPTED SOLUTION

avatar
Super Mentor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
5 REPLIES 5

avatar
Super Mentor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar

HDF 2.0. Source nifi is also running on same instance. Looking at logs, it looks like nifi is trying to communicate on public ip address, but it can't communicate. How do I specify private ip for communication.

avatar
Super Mentor

The source NiFi will initially communicate with the target cluster over the same HTTP(s) port you would use to access the target NiFi cluster's UI. After that initial communication the target cluster will provide your source NiFi with the configured nifi.remote.input.host and nifi.remote.input.port for each node in teh target cluster along with teh current load on each node.

If you left the nifi.remote.input.host blank, Java will try to determine the hostname. This may result in either an internal hostname your source can not resolve or even just localhost. I highly recommend setting this property to a public facing FQDN for each node in your cluster.

Matt

avatar

Thanks Matt. Source Nifi instance is not able to talk to target cluster because it it trying to access public ip that it can't access. I guess it is more of EC2 question, how can I get my node to communicate using public ip.

Only one of the node is public facing. Other node is not public facing and doesn't have a public facing FQDN.

avatar

Thanks Matt for your help. I finally resolved this issue by referring to internal ip of hosts.