Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Connectivity issues with hortonworks sandbox

Highlighted

Connectivity issues with hortonworks sandbox

New Contributor

Hi there, I'm trying to connect to Hortonworks Sandbox 2.5 with Oracle Virtualbox 5.1.14. I followed the installation and import instructions by the book, however, when I try to run the VM I get the following message: 'Connectivity Issues Detected! Check connection of network interface. For details, see VM setup instructions'. I've now tried this on two different machines, one running Windows 7 and the other running Windows 10. I can't find much about this particular error message online. I've tried uninstalling and reinstalling both Virtualbox and the Hortonworks ovf file.

Does anyone have any troubleshooting suggestions?

Thanks!

13 REPLIES 13

Re: Connectivity issues with hortonworks sandbox

Super Collaborator

Check what you have 'NAT' adapter in the Network settings for the VM.

Re: Connectivity issues with hortonworks sandbox

New Contributor

Yes, NAT adapter is selected and the adapter type is Intel PRO/1000 MT desktop. These were the default selections.

Re: Connectivity issues with hortonworks sandbox

Super Collaborator

That's definitely strange. Just tried a fresh install of 5.1.14 with sandbox 2.5 on my Windows 8 laptop and everything works just fine without problems.

Have you tried to start it with other setting for network adapter (I would suggest to try "Not attached") to check whether it's really adapter settings problem or something else?

Re: Connectivity issues with hortonworks sandbox

New Contributor

Yeah, I tried all of the other potential settings, but no luck with any of them

Re: Connectivity issues with hortonworks sandbox

Expert Contributor

Hi @Ben Kuhn,

One time that message comes up is when the VM cannot get a DHCP address. Do you have a valid DHCP environment? Have you tried connecting to http://127.0.0.1:8888 anyway? Sometimes it works even without good DHCP since it's being reached from your local machine.

John

Re: Connectivity issues with hortonworks sandbox

New Contributor

Hi John, I did try connecting to http://127.0.0.1:8888 anyway, but it does not work (I think the error was something along the lines of 'connection refused', I can check later if that's relevant). How do I determine whether I have a valid DHCP environment? Thanks

Re: Connectivity issues with hortonworks sandbox

Expert Contributor

Hi @Ben Kuhn,

I was thinking that you would get a DHCP address from your home network, but if you have it configured for NAT, you should not have any issues with that.

Here is what mine looks like:

11895-screen-shot-2017-01-30-at-31227-pm.png

On mine, Adapters 2, 3, and 4 all are unchecked in the "Enable Network Adapter" setting.

John

Re: Connectivity issues with hortonworks sandbox

Mentor

@Ben Kuhn

I think th eattached document will sort you out !

Let me know the outcome

Re: Connectivity issues with hortonworks sandbox

New Contributor

Hi @Ben Kuhn,

Were you able to resolve this issue? I am facing the same. If resolved, Please let me know how you have done it.

,

Hello @Ben Kuhn,

Were you able to resolve this issue? I am facing the same.