Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

ConsumeMQTT is not working with Minifi-CPP-0.5.0

Highlighted

ConsumeMQTT is not working with Minifi-CPP-0.5.0

New Contributor

Along with struggling to get a clean build using the GitHub, I have been unable to get the ConsumeMQTT processor to work.

I first started off with a base Minifi-CPP build found at https://nifi.apache.org/minifi/getting-started.html and https://nifi.apache.org/minifi/download.html


I followed all the instructions and created a flow that consisted of a ConsumeMQTT processor and an UpdateAttribute processor. This resulted in the error:

[2019-02-27 07:48:19.355] [org::apache::nifi::minifi::Properties] [info] Using configuration file located at /opt/nifi-minifi-cpp-0.5.0/conf/minifi-uid.properties
	[2019-02-27 07:48:19.355] [main] [info] MINIFI_HOME=/opt/nifi-minifi-cpp-0.5.0
	[2019-02-27 07:48:19.355] [org::apache::nifi::minifi::Properties] [info] Using configuration file located at /opt/nifi-minifi-cpp-0.5.0/conf/minifi.properties
	[2019-02-27 07:48:19.362] [org::apache::nifi::minifi::FlowController] [info] FlowController NiFi Configuration file /opt/nifi-minifi-cpp-0.5.0/conf/config.yml
	[2019-02-27 07:48:19.362] [main] [info] Loading FlowController
	[2019-02-27 07:48:19.362] [org::apache::nifi::minifi::FlowController] [info] Load Flow Controller from file /opt/nifi-minifi-cpp-0.5.0/conf/config.yml
	[2019-02-27 07:48:19.363] [org::apache::nifi::minifi::core::FlowConfiguration] [error] No Processor defined for ConsumeMQTT
	[2019-02-27 07:48:19.363] [org::apache::nifi::minifi::core::YamlConfiguration] [error] Could not create a processor ConsumeMQTT with id 5994c484-d177-3611-0000-000000000000
	[2019-02-27 07:48:19.364] [main] [error] Failed to load configuration due to exception: Could not create processor ConsumeMQTT

To check to see if the Minifi build was bad, I removed the ConsumeMQTT processor and ran the program with just an UpdateAttribute processor. Minifi appeared to be working as intended and did not throw any errors in the logs.

Next, I looked at the GitHub and confirmed that ConsumeMQTT is a supported processor. I then attempted to create a build using the GitHub. After several attempts of trying to get a successful build (Enabled MQTT using the bootstrap), I ran the flow exactly as I had tested in my previous statement. First I received the following error:

./minifi.sh: line 287: /opt/nifi-minifi-cpp-0.5.0-source/bin/minifi: No such file or directory

I am not sure why this file is missing. I did not see it in the GitHub so my assumption is that it was supposed to be created when the build was correctly created. I proceeded to copy the minifi file from the base build I had tested. Once I ran the minifi.sh script, the logs had the same error as stated prior that ConsumeMQTT was not defined.

Any suggestions on how I should proceed? Is ConsumeMQTT still a supported processor?