Support Questions
Find answers, ask questions, and share your expertise

Could not download Ambari.repo for HDP 2.6.4 upgrade. Error 404: Not Found

Solved Go to solution
Highlighted

Could not download Ambari.repo for HDP 2.6.4 upgrade. Error 404: Not Found

Explorer

I'm trying to upgrade my cluster from HDP 2.6.1 to 2.6.4. I could not download the ambari.repo 2.6.1.3-3 from the provided repository in https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.1.3/bk_ambari-upgrade/content/upgrade_ambari.ht... When I run the below command to download the ambari-repo I get the following error.

wget -nv http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.6.1.3-3/ambari.repo -O /etc/yum.repos.d/ambari.repo

Error 404: Not Found.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Could not download Ambari.repo for HDP 2.6.4 upgrade. Error 404: Not Found

New Contributor

Hi Joshva,

It seems to be you are using an invalid URL.

The URL provided in Hortonworks document " https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.1.3/bk_ambari-upgrade/content/upgrade_ambari.ht... " is " wget -nv http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.6.1.3/ambari.repo -O /etc/yum.repos.d/ambari.repo " but you are using " wget -nv http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.6.1.3-3/ambari.repo -O /etc/yum.repos.d/ambari.repo ".

Could you try to download the ambari.repo using " wget -nv http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.6.1.3/ambari.repo -O /etc/yum.repos.d/ambari.repo ".

Thanks Rajkumar.M

View solution in original post

2 REPLIES 2
Highlighted

Re: Could not download Ambari.repo for HDP 2.6.4 upgrade. Error 404: Not Found

New Contributor

Hi Joshva,

It seems to be you are using an invalid URL.

The URL provided in Hortonworks document " https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.1.3/bk_ambari-upgrade/content/upgrade_ambari.ht... " is " wget -nv http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.6.1.3/ambari.repo -O /etc/yum.repos.d/ambari.repo " but you are using " wget -nv http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.6.1.3-3/ambari.repo -O /etc/yum.repos.d/ambari.repo ".

Could you try to download the ambari.repo using " wget -nv http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.6.1.3/ambari.repo -O /etc/yum.repos.d/ambari.repo ".

Thanks Rajkumar.M

View solution in original post

Highlighted

Re: Could not download Ambari.repo for HDP 2.6.4 upgrade. Error 404: Not Found

Explorer

Thank you Rajkumar, it works now.