Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Creation of attached cluster with a datalake cluster failed

Highlighted

Creation of attached cluster with a datalake cluster failed

New Contributor

Hello,

I am using the Datalake's feature from the version 2.7.x but it seems to have a bug.

After creating the datalake cluster configured with my ldap and databases, when I try to create an attached cluster, Ambari will use the same database as the datalake.

Ambari's attached cluster should have their own instance of the database because as Ambari reads the hosts IPs from the table "hosts". Consequently since the database is the one of the Datalake Ambari, attached clusters Ambari's agent cannot connect.

To by pass this issue, I had to use the cb-cli with a custom JSON, removing the ambariRds entry.

Do you think it is a bug or it is intended ?

Thanks,

Khanh

4 REPLIES 4

Re: Creation of attached cluster with a datalake cluster failed

New Contributor

We had the same issue too. We couldn't make the attached cluster bootstrap properly, it always fails at Ambari install step. Thanks for the tips, I'm going to try out your idea

Re: Creation of attached cluster with a datalake cluster failed

Expert Contributor

I believe this is a bug in 2.7 (which is fixed), but we need to release it with 2.7.2. For now the DL does not enforce you to attach Ambari database, but only Hive and Ranger. If you don't specify Ambari for the DL then it will work. The other workaround would be to complete the wizard of the attached cluster and instead of creating the cluster click on show cli command and you can delete the Ambari database reference from the json and you can create the attached cluster via CLI.

Thanks for reporting this, we will move th fix to 2.7.x line.

Re: Creation of attached cluster with a datalake cluster failed

New Contributor

thx @khorvath

Indeed in 2.7.1 DL does not enforce to attach Ambari database.

Re: Creation of attached cluster with a datalake cluster failed