Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Data node process not starting up

Solved Go to solution
Highlighted

Data node process not starting up

Contributor

Even I have right permission my data node not starting up. Gives following error :(Connection failed: [Errno 111] Connection refused to 0.0.0.0:50010)

[root@ip pig]# cd /hadoop/hdfs/data

[root@ip hdfs]# ls -lrt

total 0

drwxr-x---. 3 hdfs hadoop 20 Apr 5 10:54 data

drwxr-xr-x. 4 hdfs hadoop 63 Apr 9 14:08 namenode

drwxr-xr-x. 3 hdfs hadoop 38 Apr 9 14:16 namesecondary

Just want to add .. last time when the everything was running i did floowing..

added the mapred user to HDFS group and given him rwx permission on / directory... can this be a reason of failure?

Just to add Not only datanode everything else is not running now.. is there any way to know what may have gone wrong?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Data node process not starting up

Contributor

Thank you all... I have got it resolved. I did 2 things..

1. for name node : I simply changed the port to some other value

2. For data-node : I found an error message in logs saying that "/" has permission 777 , cannot start data-node. I remember I had changed it manually for some other problem. Reverting it resolved the issue.

13 REPLIES 13

Re: Data node process not starting up

@Amit Sharma

Can you check if iptables and selinux is stop.

Re: Data node process not starting up

Contributor

how to do that can you please help me.

Re: Data node process not starting up

Contributor

Hi, Can anyone help me please?

Re: Data node process not starting up

Super Guru

Re: Data node process not starting up

Contributor

Commands doesn't seems to give answer.

Re: Data node process not starting up

Mentor

@Amit Sharma

Follow this personal documents substitute the names accordingly

Re: Data node process not starting up

Mentor

@Amit Sharma

Have you tried the above solutions ?

Re: Data node process not starting up

Contributor

It is not working... looks like all of my commands are failing.. non of them are able to perform task here is the attached output of commnds I ran. errors.txt

Re: Data node process not starting up

Contributor

Looks like I have disabled both of the things firewall and selinux ...still no luck.

[root@ip-xxxxxxxx ec2-user]# systemctl status firewalld.service

● firewalld.service

Loaded: not-found (Reason: No such file or directory)

Active: inactive (dead)

[root@ip-xx-xx-xx-xx ec2-user]# sestatus SELinux status: disabled

is there any logs or something which can help?