Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Datanode doesn't start - execstack required

Datanode doesn't start - execstack required

New Contributor

Hello,

We are installing hdp 2.5.3. on SLES 12 SP2 64 bit in a single node environment. Installation went fine with a couple of adjustments but we can't start the data node as it stops with the following message. We executed execstack but didnt receive any reply of the program and the error remains. We checked a couple of posts similar to the one we are observing, but we couldn't fix it so far.

Any ideas?

Thanks, Philipp

 Execution of 'ambari-sudo.sh su hdfs -l -s /bin/bash -c 'ulimit -c unlimited ;  /usr/hdp/current/hadoop-client/sbin/hadoop-daemon.sh --config /usr/hdp/current/hadoop-client/conf start datanode'' returned 1. starting datanode, logging to /var/log/hadoop/hdfs/hadoop-hdfs-datanode-hadoop26.out
Java HotSpot(TM) Server VM warning: You have loaded library /usr/hdp/2.5.3.0-37/hadoop/lib/native/libhadoop.so.1.0.0 which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
1 REPLY 1

Re: Datanode doesn't start - execstack required

New Contributor

Hi, I installed a later java version , but I assume that I didnt install the correct 64 bit version before... I could start it now.