Support Questions

Find answers, ask questions, and share your expertise

Datanode is not starting in Hadoop-2.7.2 in fully distributed mode

we have setup a hadoop(2.7.2)cluster in fully distributed mode but datanode is starting on slave machine after I ran this command ""

these are the screenshots of terminals of master(vinith),secondarymaster(harsha),slave1(balaji)

Screenshot from 2019-08-21 01-41-06.pngScreenshot from 2019-08-21 01-41-16.pngScreenshot from 2019-08-21 01-42-11.png


Super Mentor


Have you tried to start a HDFS DataNode with the following command on each designated node:

# $HADOOP_PREFIX/sbin/ --config $HADOOP_CONF_DIR --script hdfs start datanode

After starting the DataNode like above please share the DataNode log/out file if it fails to start.

Super Mentor


Also when you tried to start the components using "" then before that have you already copied the Hadoop Binary and Hadoop configuration files to slave nodes as well?

Are these slave nodes able to resolve the master node without any issue ... please check their "/etc/hosts" file as well.

Following is a blog post which you can refer just to make sure that you did not miss any step before starting the datanode.

If you still face any issue then please share the logs specially on the dataNodes whatever logs are generated.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.