Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Deploy Client Configuration failed HDFS/YARN

Deploy Client Configuration failed HDFS/YARN

Contributor

Hello all,

 

When adding HDFS or YARN using Cloudera Manager 5.4.3, I always get this error:

 

Completed only 0/7 steps. First failure: Client configuration (id=1) on host XXXXXXXXXX (id=2) exited with 1 and expected 0.

 

Havent seen anything in the error logs, also I gave 777 permission and hdfs owner to /etc/hadoop which should be the folder where the configuration is stored, but nothing helped.

 

It could be a problem that I use CM 5.4.3 while using parcel CDH 5.4.4? Like there is some misconfiguration in versions or something.

 

Thank you for any help or advice!

8 REPLIES 8

Re: Deploy Client Configuration failed HDFS/YARN

Contributor

error.PNG

Re: Deploy Client Configuration failed HDFS/YARN

Contributor

I found this problem two months ago.

https://community.cloudera.com/t5/Cloudera-Manager-Installation/Deploy-Client-Configuration-failed-a...

 

 

 

two points:

1. make a link to /usr/java/default

ln -s YOUR_JAVA_HOME /usr/java/default

 

2. add sudo nopassword to cloudera-scm user

vim /etc/sudoers

-----------------------------------

cloudera-scm    ALL=(ALL)       NOPASSWD: ALL

Re: Deploy Client Configuration failed HDFS/YARN

Contributor

Hi Sartner,

 

Thank you for responding to me!

 

If I run: 

ln -s /opt/cloudera/java/jdk1.8.0_45 /usr/java/default

I get: 

ln: creating symbolic link `/usr/java/default': No such file or directory

 

And I am not able to give cloudera-scm sudo for all commands, this is my sudo (I run sudo -l)

User cloudera-scm may run the following commands on this host:
(root) NOPASSWD: /usr/bin/yum, (root) /bin/sed, (root) /sbin/chkconfig, (root) /bin/mv, (root) /bin/rm, (root) /usr/bin/id, (root) /bin/chown, (root) /sbin/service, (root) /bin/sed, (root) /usr/bin/install

...as it is described in here:

http://www.cloudera.com/content/cloudera/en/documentation/core/latest/topics/cm_ig_permissions.html#...

 

Not sure if this is a right approach.

 

Re: Deploy Client Configuration failed HDFS/YARN

Contributor

maybe you can find some error log in 

/var/run/cloudera-scm-agent/process/ccdeploy_hadoop-conf_etchadoopconf.cloudera.hdfs_XXXXXXXXXXX/logs

when you got error in deploy client configuration (on service hdfs)

 

I got JAVA_HOME not find error in the log file 

before I make the link that JAVA_HOME to /usr/java/default (have to create parent file first, "mkdir -p /usr/java")

 

Re: Deploy Client Configuration failed HDFS/YARN

Contributor

Thank you for finding for me a way where to look for an error! I didnt know about this log and you were right, I have the same error as you had.

 

+======================================================================+
| Error: JAVA_HOME is not set and Java could not be found |
+----------------------------------------------------------------------+
| Please download the latest Oracle JDK from the Oracle Java web site |
| > http://www.oracle.com/technetwork/java/javase/index.html < |
| |
| Cloudera Manager requires Java 1.6 or later. |
| NOTE: This script will find Oracle Java whether you install using |
| the binary or the RPM based installer. |
+======================================================================+
+ exit 1

 

So I created the empty java folder:

mkdir -p /tmp/usr/java/jdk1.8.0_45

 

and then created the link:

ln -s /opt/cloudera/java/jdk1.8.0_45 /usr/java/jdk1.8.0_45

 

But this still didnt work :(

 

For what user did you set the $JAVA_HOME? I run Cloudera Manager as cloudera-scm with sudo access, so some of the processes run as root. Do you think I should somehow set the JAVA_HOME for root too?

I am working in a environment where logging as a root is not easy, so this is why I am asking beforehand.

 

Thank you very much for your help and support!

Re: Deploy Client Configuration failed HDFS/YARN

Contributor

Sudo not have the JAVA_HOME env properties. You can try "sudo -u cloudera-scm java -version"

Have to "keep env" on /etc/sudoers, http://unix.stackexchange.com/questions/6127/java-home-not-set-in-script-when-run-using-sudo

 

 

------------------------------------------

 

I'm using root to install and run the whole cluster.

 

Before this , I tried to use other accounts, but encountered a lot of trouble during the installation.

Finally I gave up doing that.

 

 

Re: Deploy Client Configuration failed HDFS/YARN

Explorer

Hi there All-

 

Had this issue today as well. None of the solutions I found were working ( I even did two uninstall/resintalls hoping that would fix it... NO). 

 

Finally figured it out after Sartners suggestion to look at that set of logs (I didn't even know those ones existed! THANK YOU). 

 

I had a symbolic link that was broken, I created it and was able to get installed. 

 

sudo ln -s /etc/hadoop/conf.cloudera.hdfs /etc/alternatives/hadoop-conf

 

Hope this helps someone else!

 

 

Re: Deploy Client Configuration failed HDFS/YARN

New Contributor

hey guys, i came to the same problem and i solved it, may this help you

 

i saw some other tips to solve the problem by linkling /usr/java/default to the ${JAVA_HOME}

 

actually it can solve the problem , but it's not the fundamental solution

 

link /usr/java/default to the ${JAVA_HOME} is used in ${CM_PATH}/lib64/cmf/service/client/deploy-cc.sh and ${CM_PATH}/lib64/cmf/service/common/cloudera-config.sh, see here

WechatIMG8898.jpeg

 

code shows us you can link other vars to ${JAVA_HOME}, not only /usr/java/default

 

so i don't think link JAVA_HOME on host is convinent 

 

you can set JAVA_HOME in cdh manager on host page, set host environment in cdh manager to fix this issue,

 

here are the stepts: cdh manager -> all hosts -> ${error_host} -> configuration -> JAVA HOEM DIRECTORY

WechatIMG8900.jpeg

 

hope this helps

 

 

Don't have an account?
Coming from Hortonworks? Activate your account here