Support Questions
Find answers, ask questions, and share your expertise

,Desired version (2.2.0.0) of ambari-agent package is not available. Repository has following versions of ambari-agent:2.1.2.1

Dear Team,

Hardware/Software Information:

I'm trying to install HDP2.2.8.0 using ambari2.1.2.1. RHEL6.5 and 64Bit is the OS.

I have configured password less ssh between nodes. So, not going with manual installation of ambari agent.

yum repolist is showing below, on NameNode server.

HDP-2.2.8.0 HDP Version - HDP-2.2.8.0 167+24 HDP-UTILS-1.1.0.20

HDP Utils Version - HDP-UTILS-1.1.0.20 43

Updates-ambari-2.1.2.1 ambari-2.1.2.1 - Updates 6

yum repolist is showing below, on my DataNode server.

Updates-ambari-2.1.2.1 ambari-2.1.2.1 - Updates

yum search ambari is showing below, on my DataNode server.

ambari-agent.x86_64 : Ambari Agent

This agent version is 2.1.2.1

PROBLEM:

During Confirming the Hosts step using ambari, able to see the below error message

========================== Running setup agent script... ========================== 
Command start time 2016-04-08 20:18:16 
Desired version (2.2.0.0) of ambari-agent package is not available. Repository has following versions of ambari-agent:2.1.2.1,
Connection to datanode1.ddns.net closed.
SSH command execution finished 
host=datanode1.ddns.net, exitcode=1 
Command end time 2016-04-08 20:18:26 
ERROR: Bootstrap of host datanode1.ddns.net fails because previous action finished with non-zero exit code (1) 
ERROR MESSAGE: tcgetattr: Invalid argument 
Connection to datanode1.ddns.net closed. 
STDOUT: Desired version (2.2.0.0) of ambari-agent package is not available. Repository has following versions of ambari-agent:2.1.2.1,

Please help me in this regard and let me know where I went wrong and what is the solution for this issue.

Regards,

PAT

K2BigTech

1 ACCEPTED SOLUTION

@c pat

Have you done a repolist on your Ambari server node and verified the installed version of the ambari-server package? The agents and server versions must match. If you have the wrong server version installed, remove it, update your repo, and do a 'yum clean all' before reinstalling the ambari-server package.

View solution in original post

4 REPLIES 4

@c pat

Have you done a repolist on your Ambari server node and verified the installed version of the ambari-server package? The agents and server versions must match. If you have the wrong server version installed, remove it, update your repo, and do a 'yum clean all' before reinstalling the ambari-server package.

After remove, clean, update and reinstallation of repo... it worked for me. Thanks!!

Yes, this is on my ambari server node.

yum repolist is showing below, on NameNode server.

HDP-2.2.8.0 HDP Version - HDP-2.2.8.0 167+24 HDP-UTILS-1.1.0.20

HDP Utils Version - HDP-UTILS-1.1.0.20 43

Updates-ambari-2.1.2.1 ambari-2.1.2.1 - Updates 6

let me re-execute the steps, what you have mentioned.

Super Collaborator

@c pat Ambari server version and agent versions should be same .

First verify if your ambari-server version is 2.1.2.1,execute below command on ambari-server

#rpm -qa ambari-server

Or if you are using GUI then it can be found with "About" from GUI (top right over click over login user name

screen-shot-2016-04-10-at-123516-pm.png

; ;