Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Disable ResourceManager HA

Solved Go to solution

Disable ResourceManager HA

New Contributor

Hi,

I'm trying to disable ResourceManager High Availablity because I cannot find a solution to a problem with proxy server redirection (YARN Exception: Could not determine the proxy server for redirection) and I want to check if the problem is gone when not using YARN HA.

I'm following the documentation to do that (Disable ResourceManager High Availability) but I'm getting an error when executing the script in step 2. I call it like this:

/var/lib/ambari-server/resources/scripts/configs.py get m0201.cl.psiori.com psiori yarn-site yarn-site.json

The hostname of the Ambari server is "m0201.cl.psiori.com" and the cluster name is "psiori" but if fails with the error:

configs.py: error: One of required options is not passed

What am I doing wrong? And why can I not simply remove the corresponding configuration values mentioned in step 3 in the Ambari UI?

Thx,
Alex

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Disable ResourceManager HA

New Contributor

I managed to get it running by specifying all the required options usind the right flags. The documentation still seams to use the command as it was used for configs.sh (before Ambari 2.6.0) but is not valid anymore for configs.py. The documentation should be adapted to the new command for configs.py.

4 REPLIES 4

Re: Disable ResourceManager HA

Super Collaborator

The usage of the script will be displayed when running it with the parameter --help or -h. From a quick look, it seems that the script expects parameter by name like

-a ACTION, --action=ACTION<br>

while you try to provide the parameter by position. I.e. instead of "configs.py get ..." it should be "configs.py -a get ..."

Ambari has some mandatory configs, that you can't delete. It should be easy to check if the parameter you want to delete are mandatory or not: locate them in the Ambari UI, and check if there is the 'delete' action icon right of the config, it looks like the traffic sign entrance forbidden. If the icon is there, you can delete them using Ambari UI.

Re: Disable ResourceManager HA

New Contributor

I already tried that but I'm getting the same error.

Highlighted

Re: Disable ResourceManager HA

New Contributor

I managed to get it running by specifying all the required options usind the right flags. The documentation still seams to use the command as it was used for configs.sh (before Ambari 2.6.0) but is not valid anymore for configs.py. The documentation should be adapted to the new command for configs.py.

Re: Disable ResourceManager HA

Super Collaborator

good to hear it worked. it would be great if you accept the answer so that this thread is marked as closed. I submitted the hint on the documentation as an idea.

Don't have an account?
Coming from Hortonworks? Activate your account here