Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Disable remote parcel repository in CM config

Solved Go to solution

Disable remote parcel repository in CM config

Explorer

I am trying to configure CM5 for parcel deployment in our PoC environment.

I currently have all my parcel files in /app/cloudera/parcel-repo and I want to use this as my repository and not have to point to any 

URL. But I am unable to disable the URL option Screen Shot 2015-09-02 at 3.40.15 PM.png

 

I want to disable this section completely. My goal is to keep all parcel files on the CM5 server "/app/cloudera/parcel-repo" directory and deploy to targets from this location alone. If I want a new parcel, I would upload it to that directory. Is it possible to do that?

 

Much appreciate your help here. 

 

aBBy007

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: Disable remote parcel repository in CM config

Explorer

Hi Lars,

 

CM appears to be smarter than that :). It does not take any http://foo.bar, so I had to install httpd on the same host where 'm installing CM5 and point the repository to it. That worked just fine. 

 

I am now running into a new problem and creating a new thread for it. 

 

Thanks,

aBBy007

Re: Disable remote parcel repository in CM config

Cloudera Employee

You add it in the wizard on this page at the bottom.

 

repos.png

13 REPLIES 13

Re: Disable remote parcel repository in CM config

New Contributor

I don't think there's a way to disable the URL checking entirely. But you can just delete all but one Repository in the Parcel settings and enter a bogus URL (i.e. http://foo.bar) in the last field. You'll get warnings in the CM Server logs but those are quite common anyway because lots of customers don't have direct Internet access to their CM machines.

 

And then you can just download the parcels and .sha1 files and move them into the parcel-repo directory. But you will have to rename the .sha1 file to .sha!

 

This works but is not the recommended way of doing it. The recommended way is to set up a simple HTTP server and mirror the Parcels you want pointing the HTTP server at it and then enter that URL in CM.

Re: Disable remote parcel repository in CM config

Explorer

Hi Lars,

 

CM appears to be smarter than that :). It does not take any http://foo.bar, so I had to install httpd on the same host where 'm installing CM5 and point the repository to it. That worked just fine. 

 

I am now running into a new problem and creating a new thread for it. 

 

Thanks,

aBBy007

Re: Disable remote parcel repository in CM config

New Contributor

Hi aBBy007,

 

hmm I'm not sure what's happened to you but the method I described definitely works. I've done it tens of times as lots of customers don't allow direct Internet access to their clusters.

 

Cheers,

Lars

Re: Disable remote parcel repository in CM config

Cloudera Employee

Running a local http server is the best way to handle this situation, so I'm glad you did that.

 

We document how to set up a local parcel mirror here:

 

http://www.cloudera.com/content/cloudera/en/documentation/core/latest/topics/cm_ig_create_local_parc...

 

While it is technically possible to directly place files on disk and convince CM to use them, there are a lot of gotchas around it and so, this is not something we recommend any more.

Re: Disable remote parcel repository in CM config

Explorer

Many Thanks Philip,

 

Indeed it turned out to be a simple solution. One qq in this same league. Now that my parcel repository is working, but when I try to deploy agent on a target host, CM seems to create a new repository on the remote host that points to archive.cloudera.com which in turn is inaccessible from that server. How can I ensure that the cloudera-manager.repo points to my internal repo?

 

aBBy007

Re: Disable remote parcel repository in CM config

Cloudera Employee

In the wizard, you can specify a custom repository to obtain the Agent from. If you choose that option, you can put in your local repo and it will be used in place of archive.cloudera.com. Of course, you must properly mirror the packages and metadata to create a compliant apt or yum repository (depending on your distro)

Re: Disable remote parcel repository in CM config

Super Collaborator

The thing to consider is you have 2 kinds of repo's, you are welcome to serve them off the same HTTP server with discrete paths.

 

1) The agent/daemons packages can be provided on your http repo through our "repo-as-tarball" download for Cloudera manager packages so you can serve them locally.

See the discussion at: http://www.cloudera.com/content/cloudera/en/documentation/core/latest/topics/cm_ig_create_local_pack...

 

2) Your parcel repository which it sounds like is already set up. 

 

 

Re: Disable remote parcel repository in CM config

Explorer

Grizzly & Phillip,

 

I have tried all options available on the net, but still 'm unable to get the rpm repository to point to my local repository. It keeps pointing back to archive.cloudera.com. Do you have steps anywhere on how to ensure that the cloudera-manager.repo file is not deployed as the default and can be customized to point to the local repo?

 

Thanks in advance folks, 

aBBy

Re: Disable remote parcel repository in CM config

Cloudera Employee

You add it in the wizard on this page at the bottom.

 

repos.png

Don't have an account?
Coming from Hortonworks? Activate your account here