Support Questions
Find answers, ask questions, and share your expertise

Disabling Kerberos on Cloudera EXpress 5.5.1: HBase issue

Explorer

Hello,

 

I have disabled the Kerberos configuration on my cluster. The hbase and Solr are not starting anymore.

 

HBASE: I have checked the 2 parameters: 

HBase Secure Authentication(hbase.security.authentication) : simple

HBase Secure Authorization(hbase.security.authorization): false

 

My master and 3 RegionServer aren't starting. I have checked the confiration generated to run the servers by the scm and the parameters are like mentionned above.

 

I have noticed anyway that the core-site.xml generated contain:

<property>
<name>hadoop.security.auth_to_local</name>
<value>RULE:[1:$1@$0](.*@\QTEST.COM\E$)s/@\QTEST.COM\E$//
RULE:[2:$1@$0](.*@\QTEST.COM\E$)s/@\QTEST.COM\E$//
DEFAULT</value>
</property>

 

Could this be the problem? Any idea is welcome, I am stuck...

 

13 REPLIES 13

New Contributor

thanks a lot mate , this saved my day !

Explorer
I too was facing this issue while disabing Kerberos authentication. Got Hbase started by these steps.
But the Thrift isn't still able to start giving this error in stderr file:
Exception in thread "main" java.io.IOException: Thrift server must run in secure mode to support authentication
at org.apache.hadoop.hbase.thrift.ThriftServerRunner.<init>(ThriftServerRunner.java:341)
at org.apache.hadoop.hbase.thrift.ThriftServer.doMain(ThriftServer.java:95)
at org.apache.hadoop.hbase.thrift.ThriftServer.main(ThriftServer.java:240)

Super Guru

@urbanlad20,

 

The exception indicates you still have QOP configured (which requires security be enabled).  You can try changing this to "None" in your Hbase Configuration (via Cloudera Manager):

HBase Thrift Authentication

Explorer
@bgooley I did this yesterday and got it reolved. Thanks!
Also I've posted a question with the title "HDFS Replication failing in BDR". Would really appreciate your help/inputs in this regard as I've been stuck on it for a week now. Need to get past this ASAP.