Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Disabling local job execution.

Highlighted

Disabling local job execution.

Explorer

Hey All,

 

Curious to find out why local jobs are still created when the values below are set as follows:

 

hive.exec.mode.local.auto=false (default)
hive.exec.mode.local.auto.input.files.max=4 (default)

 

Seems like hive.exec.mode.local.auto should disable any local jobs from running.  Yet they still do if hive.exec.mode.local.auto.input.files.max > 0 .

 

Why is that?  According to the code, appears they shouldn't be triggered anymore if hive.exec.mode.local.auto=false:

 

https://github.com/apache/hive/blob/master/ql/src/java/org/apache/hadoop/hive/ql/exec/mr/MapRedTask....

 

Cheers,

Tom

Don't have an account?
Coming from Hortonworks? Activate your account here