Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Docker VMWare 2.6.3 + mpack HDF (no install)

New Contributor


I downloaded the Hortonworks Data Platform (HDP®) version 2.6.3 on Hortonworks Sandbox (download for VMWare). I have tried to install the HDF mpack but I have the following error (2.png):

  • ambari-server install-mpack --mpack=/tmp/hdf-ambari-mpack- tar. gz -- verbose


I tried to move the HDP folder to avoid the symlink error, finally I managed to install it successfully. (I think it may fail for that reason)

  • mv /var/lib/ambari-server/resources/stacks/HDP /
  • mv /HDP /var/lib/ambari-server/resources/stacks/

Finally, I access the ambari interface to install the hdf version but have not been able to do so. (1.png)

What can I do about it?


Thank you.


Super Collaborator

Maybe this manual helps you, you'll have to change the URL for Ambari when you install HDF on an existing HDP:

New Contributor

Thanks for the answer, Harald.

I have tried that option, but I can't install it either, I have the same error with symlink.

Super Collaborator

I think the management pack needs to be installed first, then the URL needs to be changed,and then it should be working with Ambari.

But: can you see from the log which file or symlink already exists? Maybe we can solve the issue on this direction.

Super Collaborator

Here is a supportkb entry, which sounds like your issue:

Seems to be related to components that are included in HDP and HDF.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.