Support Questions

Find answers, ask questions, and share your expertise

Does tagsync by default sync changes to tag attributes?

When I assign a tag to a hive_column in Atlas, I also set some attributes for that tag/column intersection. I then use those for policy creation in Ranger. But when I then change the attribute value on a column in Atlas, I don't see that change being reflected in Ranger. Could this be the case? Is it supposed to sync that change?

1 ACCEPTED SOLUTION

4 REPLIES 4

Yes, they should get sync'ed.

What would be the way of troubleshooting this? I see something in the tagsync.log file about access denied to some key file but not sure if that's related. I also see this which might be a bit more worrying.

ERROR AtlasNotificationMapper [Thread-7] - 142 TRAIT_UPDATE: unknown notification received - not handled

Any ideas?

Thanks

Having raised to DEBUG on the tagsync logging I also see this:

07 Feb 2018 07:46:41 DEBUG AtlasTagSource [Thread-7] - 172 Notification={ Notification-Type: TRAIT_UPDATE, AtlasEntityWithTraits={ Entity-Id: 55ef8247-6651-4c37-82ed-c428bea50057, Entity-Type: hive_column, Entity-Version: 0, Entity-State: ACTIVE, Entity-Values={ {owner, raj_ops}, {qualifiedName, default.employee.ssn@Sandbox}, {name, ssn}, {position, 0}, {type, string}, {table, (type: hive_table, id: 96bb1405-d122-4449-90d8-6ad08a1aa250)}, }, Entity-Traits={ {traitType=Confidentiality, {{PII, ye}} } } }}
07 Feb 2018 07:46:41 ERROR AtlasNotificationMapper [Thread-7] - 142 TRAIT_UPDATE: unknown notification received - not handled.

The attribute changed in Atlas is Confidentiality.PII, the value is changed to "ye". This comes through to Ranger but it seems Ranger cannot process it.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.