Support Questions
Find answers, ask questions, and share your expertise

Downgrade of Ambari 2.2 to 2.1

Hi,

I need a advice how to correctly downgrade Ambari from 2.2 to 2.1, I haven't seen any docs about it.

My issue is described here, I already upgraded Ambari from 2.1 to 2.2, but I have HDP 2.0.6 (HDFS/MapReduce2/YARN on version 2.1.0.2.0), so my Ambari 2.2 doesn't work correctly with HDP 2.0. I have to downgrade Ambari or upgrade HDP, but when I want to upgrade HDP:

Ambari 2.2 does not support managing an HDP 2.0 cluster. If you are running HDP 2.0, in order to use Ambari 2.2 you must first upgrade to HDP 2.1 or higher using either Ambari 1.7 or 2.0 prior to upgrading to Ambari 2.2. Once completed, upgrade your current Ambari to Ambari 2.2.

I know how to change repo for downgrade, but Ambari server DB schema 2.2 is not working with Ambari 2.1, is there any script howto change back DB schema?

Or is there a any chance to upgrade my HDP 2.0.6 to version of HDP which works with Ambari 2.2 without using Ambari? I see there is a Non-Ambari Cluster Upgrade Guide.

1 ACCEPTED SOLUTION

Have you taken a backup of your Ambari DB before Ambari upgrade? If so, you can uninstall your new version of ambari-server and ambari-agents on all nodes, delete the ambari database (by default it's called ambari, usually in Postgres), restore your DB backup, and re-install your old version of Ambari.

You can also upgrade HDP-2.0 to 2.1 manually, here is the manual, and you can even upgrade manually to 2.2.

View solution in original post

2 REPLIES 2

Have you taken a backup of your Ambari DB before Ambari upgrade? If so, you can uninstall your new version of ambari-server and ambari-agents on all nodes, delete the ambari database (by default it's called ambari, usually in Postgres), restore your DB backup, and re-install your old version of Ambari.

You can also upgrade HDP-2.0 to 2.1 manually, here is the manual, and you can even upgrade manually to 2.2.

Mentor

You can find schemas in /var/lib/ambari-server, just keep looking. I am not sure it will work though. As i havent heard of downgrades. This is quite a predicament and backups are your only bet. Upgraae HDP is probably the other option. @Pavel Hladík

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.