Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

ERROR: SmartSense service definition version in ambari is newer (1.5.1.2.7.3.0-139) than currently installed version (1.5.0.2.7.1.0-169)

ERROR: SmartSense service definition version in ambari is newer (1.5.1.2.7.3.0-139) than currently installed version (1.5.0.2.7.1.0-169)

New Contributor
while installing, getting this error..please help

It appears that Ambari was upgraded but post upgrade steps to upgrade SmartSense were not completed.
SmartSense stack version in Ambari is higher (1.5.1.2.7.3.0-139) than installed smartsense-hst package version (1.5.0.2.7.1.0-169).

Perform following steps to finish the upgrade:
1. Make sure that the smartsense-hst package on every host is upgraded to the latest version (1.5.1.2.7.3.0-139 or higher).
2. run 'hst upgrade-ambari-service' on Ambari server host to finish the upgrade.
3. Restart all SmartSense components.

Refer SmartSense upgrade documentation available at https://docs.hortonworks.com/ for more details.
3 REPLIES 3
Highlighted

Re: ERROR: SmartSense service definition version in ambari is newer (1.5.1.2.7.3.0-139) than currently installed version (1.5.0.2.7.1.0-169)

Super Mentor

@rakesh m

Above message can appear if you have upgraded Ambari to 2.7.3 but not performed the "Post Upgrade Task" like Upgrading the "SmartSense" as mentioned in the following Doc:

https://docs.hortonworks.com/HDPDocuments/Ambari-2.7.3.0/bk_ambari-upgrade-major/content/upgrading_s...

.

On All Hosts
# yum upgrade smartsense-hst    

On Ambari Server Host:
# hst upgrade-ambari-service

Restart Ambari Server
# ambari-server restart

There are other Ambari Post Upgrade tasks which you should take a look and perform the task like Upgrading Ambari Metrics Collector ...etc.

Re: ERROR: SmartSense service definition version in ambari is newer (1.5.1.2.7.3.0-139) than currently installed version (1.5.0.2.7.1.0-169)

New Contributor

sorry if i did not explain the properly.

this is new installation on a standalone host.

Installing latest version of HDP 3.1 using ambari latest.

i understand that from the error message that

"SmartSense service definition version in ambari is newer (1.5.1.2.7.3.0-139) than currently installed version (1.5.0.2.7.1.0-169). Please upgrade smartsense package on this host and retry the command."

but i could not find 1.5.1.2.7.3.0-139 anywhere on the hortonworks.


kindly help

Thanks

Re: ERROR: SmartSense service definition version in ambari is newer (1.5.1.2.7.3.0-139) than currently installed version (1.5.0.2.7.1.0-169)

Super Mentor

@rakesh m

SmartSense should come from Ambari Repository. Please check the version installed on your host:

# yum info smartsense-hst    

.

So if you are using Ambari 2.7.3 then you should simply do

# yum install smartsense-hst   
# hst upgrade-ambari-service

.

As i am suspecting that you might not be on the tested and certified version of Operating System based on your recent answerf on another Thread. So please refer to Support Matrix and check if your Operating System/JVM ..etc are supported?

https://supportmatrix.hortonworks.com/

.

Your Other thread: https://community.hortonworks.com/questions/232366/failed-to-execute-command-usrbinyum-y-install-had...

.

Don't have an account?
Coming from Hortonworks? Activate your account here