Support Questions
Find answers, ask questions, and share your expertise

Elasticsearch version mismatch

Master Collaborator

I am using HDP2.5 and I have /usr/hdp/current/hive-client/lib/elasticsearch-hadoop-2.2.0.jar

when i try to insert into a hive elasticsearch table i am getting this error.

The hadoop version seems to be 2.7

[root@hadoop1 lib]# hadoop version
Hadoop 2.7.3.2.5.3.0-37
HiveException: org.elasticsearch.hadoop.EsHadoopIllegalArgumentException: Unsupported/Unknown Elasticsearch version 5.5.0
1 ACCEPTED SOLUTION

Accepted Solutions

Master Collaborator

this issue was resolved by downloading the elastic search for hadoop version 5.5.0

View solution in original post

1 REPLY 1

Master Collaborator

this issue was resolved by downloading the elastic search for hadoop version 5.5.0

View solution in original post