Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Enable High Availability for HDFS , How can I input JournalNode Edits Directory

Highlighted

Enable High Availability for HDFS , How can I input JournalNode Edits Directory

New Contributor

when I enable HA of hdfs from cloudera manager 5.8.1  ,  It  must select 3 or more journalnode , It's right.

 

but next step  of    Review Changes  ,  when  input  JournalNode Edits Directory,  if I input   path  "/path/to/journallog" , it alert  "the other two in empty."  

 

and there is  no  Add button to add other journalnode  Edits Directory  .   

 

How can I ?

 

Thank you for any help.

18 REPLIES 18

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

Cloudera Employee

Hi,

 

If I understand correctly, you selected three JournalNode hosts, but the Review Changes page of the Enable High Availability wizard only presented a single text box for entering the JournalNode edits directory. Is that accurate?

 

You should see something like the following, with three separate text boxes for entering the edits directories:

 

 

Screen Shot 2016-09-19 at 8.41.29 PM.png

Can you post a screenshot of what you're seeing when you get to this page of the wizard?

 

Regards,

Mark

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

New Contributor
Hi: You said is right . only one textarea for 3 journalnode and not like NameNode Data Directories , namenode data directories have add button. if I input something like this " node1:/data/dfs/journallog node2:/data/dfs/journallog " , error occured like below -----------------------------------------------------------------error start ------------------------------------------------ There are the following errors on the page: JournalNode Edits Directory: Path node1:/data/dfs/journallog node2:/data/dfs/journallog does not conform to the pattern "(/[-+=_.a-zA-Z0-9]+)+(/)*". Value of JournalNode Edits Directory of role on hadoop.pre04 cannot be empty Value of JournalNode Edits Directory of role on hadoop.pre03 cannot be empty --------------------------------------------------------------error end ---------------------------------------------------- I am sorry I cann't screenshot for you , the internet is too slow . if you can give me a email address .

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

Cloudera Employee

First, note that the paths for the JournalNode edits directories are simple absolute paths like /x/y . There should be no "node:" prefix. That is why you are getting the error about the paths not matching the regular expression.

 

Second, your mention of an "add button" makes me think that we might not be talking about the same thing. From your description, it sounds like you might be working through the Add Cluster wizard, as opposed to the Enable High Availability wizard.

 

To set up an HA cluster with Cloudera Manager, you need to execute the following steps:

 

1. Using the Add Cluster wizard (available from the "Add Cluster" button on the home page), create a non-HA cluster.

2. Once this cluster is set up, go to the HDFS status page.

3. Using the "Actions" pull-down menu at upper right, select "Enable High Availability."

 

Please post the steps you have taken so far to get to this point.

 

Regards,

Mark

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

New Contributor

QQ图片20160920130806.png

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

New Contributor

Hi:

 

Thank you for your replay.  I did everything like you said .  And  post the error page  up .   The problem is how can I

 

input a path for 3 journalnode  in one textarea. 

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

New Contributor

QQ图片20160921201120.png\

 

and if I config journalnode edit befor enable hdfs HA , it will occur error like  this .  

 

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

Cloudera Employee

I notice that there is only one group showing up in the Review Changes page: "hadoop." I assume that that is not the name of a host in your cluster - is that correct?

 

Is there any chance that the standby NameNode and JournalNode roles already exist, or were created outside of the wizard? Or possibly left over from a previous failed run of the wizard?

 

Before invoking the wizard, the cluster should be in a non-HA state: that is, there should be only NameNode, and no JournalNodes.

 

Mark

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

New Contributor
Yes, I had a previous failed run of the wizard. But, the cluster is right , one namenode ,one secondarynamenode and some datanodes.

and how can I fix the problem now? if I had a previous failed run.

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

Cloudera Employee

Your cluster appears to be in an inconsistent state. It's difficult to be sure how to get it back into a state where the Enable HA wizard will work. But here are a few things you could try. Before trying any of these, if you have data that you care about in HDFS, make a backup.

 

1. You can't enter more than one JournalNode path in the text box. But have you tried entering just a single path, that will work on all of the JournalNode hosts?

 

2. You could try running the "Disable High Availability" command from the Actions menu, if it is available (not greyed out). I suspect it will be greyed out, though.

 

3. You could try running the Enable High Availability command using the Cloudera Manager API, rather than the wizard. More information is at https://cloudera.github.io/cm_api/.

 

Mark

Don't have an account?
Coming from Hortonworks? Activate your account here