Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Enable High Availability for HDFS , How can I input JournalNode Edits Directory

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

New Contributor
hadoop is not one of my cluster host.
but my host name is like hadoop.pre[01,02,03,04]
Highlighted

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

Cloudera Employee

I think I see what is going on.

 

Your host names are hadoop.pre01, hadoop.pre02, etc. They are not fully qualified domain names.

 

I believe a few places in the code, it is assuming the hostnames look like hostname1.domain.com, hostname2.domain.com.

 

It assumes the first part of the hostname is unique, except in this case, it is not.

 

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

New Contributor

 

Thank you for your replay.  Recently  , I will change hostname and replay you after that.

 

 

Tom

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

New Contributor
i got the same problem Did you solve it?

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

Champion

@yuannit Let me know more about the error and share your error log 

how are you configuring ? 

are you manaing your cluster using Cloudera manager ? or command line . 

did you install all the pre-requists daemons for your HA HDFS ? 

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

New Contributor

Thank you very much for your reply
Yes my cluster is managed using cloudera-manager
I am by downloading a series of cloudera-manager-service.rpm files installed locally in the yum repo
Now cluster all ok but only HDFS ha I can not install through cloudera-manager successfuly, I try to upgrade cm from 5.11.1 to 5.12 But still encounter this problem, I think this problem is not incidental,
I follow the official tutorial after the installation of the correct HDFS service and then click on the high available, fill in the JournalNode edits dir only show a line of input box, I checked the log files are no abnormal information,

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

New Contributor

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

Explorer

  I fixed the problem.

I manually edit the JournalNode Edits Directory  field and entered '/mnt/disk1/dfs/jnn' value then I was able to create HA without any issue. 

Re: Enable High Availability for HDFS , How can I input JournalNode Edits Directory

Champion

@cuizhaohua

 

You host file should like something like this 

/etc/hosts

192.168.200.11  master
/etc/sysconfig/network 

HOSTNAME=master
NETWORKING =yes

Do you still have secondarynamenode hanging around  in your HA cluster ? you have mentioned in your previous post

Don't have an account?
Coming from Hortonworks? Activate your account here