Support Questions
Find answers, ask questions, and share your expertise

Enable Kerberos namenode start failed

Solved Go to solution
Highlighted

Re: Enable Kerberos namenode start failed

Contributor

After I reinstall kerberos, it looks like ok and I start NameNode and install other service also good. But I can not find why it failed previous.

Thank you for your help.

Highlighted

Re: Enable Kerberos namenode start failed

Explorer

@Zhao Chaofeng - I am having exact problem with Hbase (1.1.2) - GSS Initiate failed even with a valid kerberos service ticket. Can you please let me know what version of kerberos libraries did you re-install? I am using Kerberos 5 version 1.10.3

Thanks! Sumit

Highlighted

Re: Enable Kerberos namenode start failed

Contributor

Kerberos 1.15. I install it with repo of CentOS 7.

Highlighted

Re: Enable Kerberos namenode start failed

New Contributor

Check your "/etckrb5.conf"

("default_tgs_enctypes" ; "default_tkt_enctypes" ; "permitted_enctypes" must contain encryption types you use.

Renewing your ticket can help ...

here for example, launch this command :

kinit -kt /etc/security/keytabs/hdfs.headless.keytab hdfs-hdp_dev@EXAMPLE.COM

Re: Enable Kerberos namenode start failed

Mentor

@Zhao Chaofeng

Is this thread still open? i.e hasn't this problem been resolved?

Please revert

View solution in original post