Support Questions
Find answers, ask questions, and share your expertise

Enabling JMX for Nifi

Hello,

We are trying to enable jmx for Nifi and added below config to bootstrap conf of nifi

-Dcom.sun.management.jmxremote.local.only=true -Dcom.sun.management.jmxremote -Dcom.sun.management.jmxremote.authenticate=false -Dcom.sun.management.jmxremote.ssl=false -Dcom.sun.management.jmxremote.port=30008

I do see that Nifi process has started with these VM parameters, however, the JMX port is not being listened.

Am I missing anything ? This works for any other java process.

1 ACCEPTED SOLUTION

Accepted Solutions

ok adding as below in bootstrap conf helped

java.arg.18=-Dcom.sun.management.jmxremote.local.only=true

java.arg.19=-Dcom.sun.management.jmxremote 

java.arg.20=-Dcom.sun.management.jmxremote.authenticate=false

 java.arg.21=-Dcom.sun.management.jmxremote.ssl=false

 java.arg.22=-Dcom.sun.management.jmxremote.port=30008

View solution in original post

5 REPLIES 5

ok adding as below in bootstrap conf helped

java.arg.18=-Dcom.sun.management.jmxremote.local.only=true

java.arg.19=-Dcom.sun.management.jmxremote 

java.arg.20=-Dcom.sun.management.jmxremote.authenticate=false

 java.arg.21=-Dcom.sun.management.jmxremote.ssl=false

 java.arg.22=-Dcom.sun.management.jmxremote.port=30008

View solution in original post

@Santhosh B Gowda

I am trying to monitor NIFI using JMX. Do you know how to enable JMX for HDF Ambari based Nifi cluster?

Thanks

Super Guru

I have updated "Advanced nifi-bootstrap-env" config on Ambari as below and restarted NIFI service. But still I don't see any metrics coming up on http://nifi1:7071/metrics

Am I missing anything ?

93052-ambari-nifi-config.png