Support Questions
Find answers, ask questions, and share your expertise
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Error CDH5 oozie

Re: Error CDH5 oozie

New Contributor

I did the same thing and at first it failed because the database didn't exist.  I had to recreate the database and set the password, and then the cluster install worked.  Here are the exact instructions;


To do this, you will need the root password (found from a file in the system as shown below) and the oozie password.  Early on in the configuration, it asked you to write them down.  I took a screenshot.  In any event, make sure you have it so you can reset the password after.


> cat /var/lib/cloudera-scm-server-db/data/generated_password.txt
<your password>

The password above was generated by /usr/share/cmf/bin/ (part of the cloudera-manager-server-db package)
and is the password for the user 'cloudera-scm' for the database in the current directory.

Generated at 20171106-141157.

> psql -U cloudera-scm -p 7432 -h localhost -d postgres
Password for user cloudera-scm: <enter password from above>

psql (9.5.9)
Type "help" for help.

postgres=# \l
                                                List of databases
        Name        |       Owner        | Encoding |  Collate   |   Ctype    |         Access privileges         
 amon               | amon               | UTF8     | en_US.UTF8 | en_US.UTF8 | 
 hive               | hive               | UTF8     | en_US.UTF8 | en_US.UTF8 | 
 nav                | nav                | UTF8     | en_US.UTF8 | en_US.UTF8 | 
 navms              | navms              | UTF8     | en_US.UTF8 | en_US.UTF8 | 
 oozie_oozie_server | oozie_oozie_server | UTF8     | en_US.UTF8 | en_US.UTF8 | 
 postgres           | cloudera-scm       | UTF8     | en_US.UTF8 | en_US.UTF8 | 
 rman               | rman               | UTF8     | en_US.UTF8 | en_US.UTF8 | 
 scm                | scm                | UTF8     | en_US.UTF8 | en_US.UTF8 | 
 template0          | cloudera-scm       | UTF8     | en_US.UTF8 | en_US.UTF8 | =c/"cloudera-scm"                +
                    |                    |          |            |            | "cloudera-scm"=CTc/"cloudera-scm"
 template1          | cloudera-scm       | UTF8     | en_US.UTF8 | en_US.UTF8 | =c/"cloudera-scm"                +
                    |                    |          |            |            | "cloudera-scm"=CTc/"cloudera-scm"
(10 rows)
postgres=# DROP DATABASE oozie_oozie_server;
postgres=# CREATE DATABASE oozie_oozie_server;
postgres=# ALTER DATABASE oozie_oozie_server OWNER TO oozie_oozie_server;
postgres=# \password oozie_oozie_server
Enter new password: <Enter oozie database password>
Enter it again: <Enter again>
postgres=# \q


Then click "back" in the "Cluster Setup" page, and then click "Continue".  It will restart all the steps, but the first ones should complete quickly.  When it got to oozie this time, instead of failing right away, it completed the process.




Hope this works for anyone else.


NOTE: I am not familiar with postgres .  It is possible that dropping only the schema will work without the extra steps of recreating the database and knowing the password.  What I did worked so I never got a chance to play around with it.


Don't have an account?
Coming from Hortonworks? Activate your account here