Support Questions
Find answers, ask questions, and share your expertise

Error While installing HDP search

Error While installing HDP search

I am trying to install HDPsearch but facing an error:

018-07-21 05:15:10,392 - File['/etc/yum.repos.d/ambari-hdp-1.repo'] {'content': ...}
2018-07-21 05:15:10,392 - Writing File['/etc/yum.repos.d/ambari-hdp-1.repo'] because contents don't match
2018-07-21 05:15:10,393 - Package['unzip'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2018-07-21 05:15:10,527 - Skipping installation of existing package unzip
2018-07-21 05:15:10,528 - Package['curl'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2018-07-21 05:15:10,542 - Skipping installation of existing package curl
2018-07-21 05:15:10,543 - Package['hdp-select'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2018-07-21 05:15:10,558 - Skipping installation of existing package hdp-select
2018-07-21 05:15:10,560 - The repository with version 2.6.5.0-292 for this command has been marked as resolved. It will be used to report the version of the component which was installed
2018-07-21 05:15:10,561 - Skipping stack-select on SOLR because it does not exist in the stack-select package structure.
2018-07-21 05:15:10,817 - Using hadoop conf dir: /usr/hdp/2.6.5.0-292/hadoop/conf
2018-07-21 05:15:10,820 - Package['lucidworks-hdpsearch'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2018-07-21 05:15:10,936 - Installing package lucidworks-hdpsearch ('/usr/bin/yum -d 0 -e 0 -y install lucidworks-hdpsearch')
2018-07-21 05:15:28,753 - Execution of '/usr/bin/yum -d 0 -e 0 -y install lucidworks-hdpsearch' returned 1. Package lucidworks-hdpsearch-2.6.1-100.noarch.rpm is not signed
2018-07-21 05:15:28,753 - Failed to install package lucidworks-hdpsearch. Executing '/usr/bin/yum clean metadata'
2018-07-21 05:15:29,564 - Retrying to install package lucidworks-hdpsearch after 30 seconds
2018-07-21 05:16:38,869 - The repository with version 2.6.5.0-292 for this command has been marked as resolved. It will be used to report the version of the component which was installed
2018-07-21 05:16:38,870 - Skipping stack-select on SOLR because it does not exist in the stack-select package structure.

I have followed below commands for installing HDPsearch from ambari :

cd /tmp
wget http://public-repo-1.hortonworks.com/HDP-SOLR/hdp-solr-ambari-mp/solr-service-mpack-2.2.9.tar.gz

ambari-server install-mpack --mpack=/tmp/solr-service-mpack-2.2.9.tar.gz

2 REPLIES 2

Re: Error While installing HDP search

However I have run the below command for the error :

Package lucidworks-hdpsearch-2.6.1-100.noarch.rpm is not signed

rpm --import http://public-repo-1.hortonworks.com/HDP-SOLR-2.6.1-100/repos/centos6/RPM-GPG-KEY/RPM-GPG-KEY-Jenkin...

but it did not help .

Re: Error While installing HDP search

Hi @Anurag Mishra

As a workaround, you can set "gpgcheck" to 0 within /etc/yum.repos.d/ambari-hdp-1.repo but be aware that that's not recommended if you have security desires for your environment.
In case you're following these steps, https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.0/bk_solr-search-installation/content/ch_hdp-..., make sure you've executed the GPG key import steps.