Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Error in PutS3Object

avatar
Contributor

I encounter a strange behavior when uploading files to S3 using PutS3Object process. It raises the following error:

ERROR [Timer-Driven Process Thread-6] o.a.nifi.processors.aws.s3.PutS3Object PutS3Object[id=12b0e9ff-0159-1000-ffff-ffffeedc377a] Error checking S3 Multipart Upload list for graphdb-poc-rawdata/: Key is not expected for the GET method ?uploads subresource (Service: Amazon S3; Status Code: 400; Error Code: InvalidRequest; Request ID: AC706A3B0F7DF2B9)

But, the strange thing is that despite of this error I do see that files are actually uploaded to S3 bucket. Is there anything wrong with what I'm doing? I'll appreciate any suggestion how to fix this.

10499-2016-12-19-14-05-27.jpg

Thank you!

1 ACCEPTED SOLUTION

avatar
Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
14 REPLIES 14

avatar

Can you please share your 1. S3 Bucket policy 2. Cors configuration. 3. NiFI processor config. You can check https://community.hortonworks.com/articles/49467/integrating-apache-nifi-with-aws-s3-and-sqs.html for reference.

avatar
Super Collaborator

you may be missing something in the s3 policy. Looks like the code is trying to read the data after uploading and then failing. May you should give permissions to read what is being uploaded to the bucket.

avatar
Contributor

Thank you! I will check with AWS admin

avatar

@Michael Kalika,

I am facing the same issue. Can I know how we remediated this issue even though file is created without any issues in AWS S3.

avatar

Did you ever figure this out? We are expereincing the same error even with extra perms added to the user for the bucket we are getting errors for

avatar
Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar

We were getting same issue and it was because our PutS3Object had directory information in the Bucket field and just the filename in the Object Key field. We changed it so that the Bucket itself was the only thing in the Bucket field and all the directory and filename information was in the Object Key field.

avatar
@Simon Engelbert

Thanks. Its perfectly working. Nice work.

avatar
New Contributor

Thank you. Worked perfect!!