Support Questions
Find answers, ask questions, and share your expertise

Error in tutoria-1 & 2

New Contributor



I dont understand the codes in tutoria-1 & 2. However, my queries are not becoming successfull as I was able to create only the 'category' table. I duly copied & pasted all the codes in terminal but it generated one table (category) only instead of six. While I tried to repeat it again & again, it shows only that the 'category' table exist. Help me please. I am just fraeking out!!



Master Collaborator
Do you have the output from the first attempt to run Sqoop? If it failed
halfway through, that output is the only way to know what went wrong. If
you don't, we can just delete the table and try again. There are 2 parts to
this, first, let's delete the table in Hive: run 'hive' from the
command-line, and when it presents you with a new prompt, enter 'drop table
category;', and then 'exit;'. Second, let's delete the underlying datafile:
run 'sudo -u hdfs hadoop fs -rm -r /user/hive/warehouse/category' on the

New Contributor
I tried, I get only the categories table. The same problem as Tanver above. What else can I do to get the six tables?

Master Collaborator

Follow my reply: if there was a failure after 1 table, there are several possible causes. If you have the output from your 1st attempt please post it. Otherwise, you'll need to delete that table and try again.