Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Error installing KAFKA 0.8.x (0.8.2.0-1.kafka1.4.0.p0.56) on Quickstart CDH 5.7

Error installing KAFKA 0.8.x (0.8.2.0-1.kafka1.4.0.p0.56) on Quickstart CDH 5.7

New Contributor

0. Downloaded Quickstart CDH 5.7, using VM Player ver.

  0.a. verified spark 1.6 via sparh-shell

1. Migrated to parcel using desktop icon.

2. Added parcel for kafka 0.8.x repo: http://archive.cloudera.com/kafka/parcels/1.4.0/

 

Error while activation

CDH (5.2 and higher) parcel required for KAFKA (0.8.2.0-1.kafka1.4.0.p0.56) is not available

 

On the parcels tab,

CDH 5      5.7.0-1.cdh5.7.0.p0.45  shows as available to download/dist/act. 
Going to activate this to see if this helps. Not sure if this is needed since 5.7 is already packaged with the quickstart.

 

2 REPLIES 2

Re: Error installing KAFKA 0.8.x (0.8.2.0-1.kafka1.4.0.p0.56) on Quickstart CDH 5.7

Contributor

If the 5.7 parcel is only shown as available, then something failed with the parcel migration tool (if you still have the output from that command, I'd love to see it to know what went wrong).

 

Although 5.7 is packaged with the QuickStart VM, it's done with Linux packages so that Cloudera Manager is optional. Dependencies for parcels must be satisfied with parcels, so having the CDH parcel activated is required before you can use the KAFKA parcel.

Highlighted

Re: Error installing KAFKA 0.8.x (0.8.2.0-1.kafka1.4.0.p0.56) on Quickstart CDH 5.7

New Contributor

Sean, What is the log file location for the migration to parcel, I can check if that is around & I can send you the file.

I went ahead with activating it & things are moslty OK, except for I cannot can spark-shell. Looking into that to see where it stops.