Support Questions
Find answers, ask questions, and share your expertise

Error when checking sandbox version - Require an Selinux enabled system

Error when checking sandbox version - Require an Selinux enabled system

New Contributor

I just installed Oracle VMWare and Horton Works. I was able to login to Ambari Sandbox. However when check sandbox -version for the status I get an error

/bin/sandbox: Requires an SELinux enabled system

Thought I might be missing some parameters. checked /etc/sysconfig/selinux

I attached the link

Want to make sure everything is okay.


selinux-error.png
2 REPLIES 2
Highlighted

Re: Error when checking sandbox version - Require an Selinux enabled system

Super Mentor

@Chaya Patamalla

I guess SELinux should be in Disabled state:

Example:

[root@sandbox ~]# sestatus
SELinux status:                 disabled

.

Are you logging into the sandbox using SSH port 2222 (or you are running the "sandbox -version" command outside the actual sandbox host)

If you want to find the HDP sandbox version & details then you can try this:

# ssh root@127.0.0.1 -p 2222

[root@sandbox ~]# cat /root/sandbox.info
Sandbox information:
Created on: 19_04_2017_19_09_16 for
Hadoop stack version:  Hadoop 2.7.3.2.6.0.3-8
Ambari Version: 2.5.0.5-1
Ambari Hash: 0b5e975972e7a0b265e87b2e38eefde9039ef44c
Ambari build:  Release : 1
Java version:  1.8.0_121
OS Version:  CentOS release 6.9 (Final)

.

Highlighted

Re: Error when checking sandbox version - Require an Selinux enabled system

Super Mentor

@Chaya Patamalla

Looks like the "/bin/sandbox" command is not same asHDP sandbox

https://www.systutorials.com/docs/linux/man/8-sandbox/