Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Error while configuring NameNode High Availability

Solved Go to solution

Error while configuring NameNode High Availability

Contributor

My setup Ambari : 2.4.2, HDP : 2.5.3.0

I have total 4 instances on openstack.

In which Primary NameNode : pbhagade-1.openstacklocal

Secondary NameNode : pbhagade-2.openstacklocal

I faced issue while configuring HA, So tried to recreate the issue and posting the same below.

After Enabling NameNode HA

Under Enable NameNode HA Wizard in Select Hosts section its recommend to use Additional NN where SNN resides right.

I see in configuration files doesn’t get updated when I change the location for Additional NN from Recommended 2nd instance(pbhagade-2.openstacklocal) to 3rd instance (pbhagade-3.openstacklocal).

After making the changes, configuration file under Review section in HA wizard doesn't changed and it still points to recommended instance.

properties which needs to changed:

dfs.namenode.http-address.nameservice1.nn2

dfs.namenode.https-address.nameservice1.nn2

I have attached the both scenario’s screenshot.

First is recommended one and other is changed one. @Sagar Shimpi15838-1.png

15839-2.pnga

and other is changing the instance location for Additional NameNode 11.png

3.png4.png

15851-4.png

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Error while configuring NameNode High Availability

@Pravin Bhagade

Hi praveen,

it seemse you are performing some wrong step. I tested it on my local system and it works as expected.

Will send you the video link of the steps performed.

3 REPLIES 3
Highlighted

Re: Error while configuring NameNode High Availability

@Pravin Bhagade

Hi praveen,

it seemse you are performing some wrong step. I tested it on my local system and it works as expected.

Will send you the video link of the steps performed.

Re: Error while configuring NameNode High Availability

Contributor

Hi Sagar, I checked it again. Found that, If we choose a host for Additional NameNode and click on next, Later if we need to change host for Additional NameNode the configuration file remains the same. So, to resolve the issue we need to open new Enable NameNode HA Wizard to change the host, we can't perform it on same wizard.

Re: Error while configuring NameNode High Availability

Contributor

NameNode HA has been enabled successfully.

Don't have an account?
Coming from Hortonworks? Activate your account here