Support Questions
Find answers, ask questions, and share your expertise

Error while install CDH 5.19

New Contributor

Hi, 

 

I am getting this error -> 

 

 Deploy client configuration on <xxxx>

 

+ sudo rm -rf /etc/spark/conf.cloudera.spark_on_yarn

sudo: sorry, you must have a tty to run sudo

 

 

while install CDH 5.19

 

OS - CentOS 6.7 (64-bit).

Single User Mode

1 Node Installation

 

 

/var/log/cloudera-scm-agent/cloudera-scm-agent.log
[24/Feb/2018 20:38:31 +0000] 9061 MainThread agent WARNING Long HB processing time: 9.45233106613
[24/Feb/2018 20:38:36 +0000] 9061 MainThread client_configs INFO Client configs to delete: set([])
[24/Feb/2018 20:38:36 +0000] 9061 MainThread client_configs INFO Client configs to deploy: set([<spark-conf,/etc/spark/conf.cloudera.spark_on_yarn>, <hbase-conf,/etc/hbase/conf.cloudera.hbase>, <hadoop-conf,/etc/hadoop/conf.cloudera.hdfs>, <hadoop-conf,/etc/hadoop/conf.cloudera.yarn>, <hive-conf,/etc/hive/conf.cloudera.hive>, <solr-conf,/etc/solr/conf.cloudera.solr>])
[24/Feb/2018 20:38:36 +0000] 9061 MainThread client_configs INFO Client configs to update: set([])
[24/Feb/2018 20:38:36 +0000] 9061 MainThread parcel INFO prepare_environment begin: {}, [u'cdh'], [u'hdfs-client-plugin', u'cdh-plugin', u'yarn-plugin', u'mapreduce2-plugin']
[24/Feb/2018 20:38:36 +0000] 9061 MainThread parcel INFO No parcels activated for use
[24/Feb/2018 20:38:36 +0000] 9061 MainThread __init__ INFO Extracted 9 files and 0 dirs to /var/run/cloudera-scm-agent/process/ccdeploy_hadoop-conf_etchadoopconf.cloudera.yarn_261985879517785900.
[24/Feb/2018 20:38:37 +0000] 9061 MainThread parcel INFO prepare_environment begin: {}, [u'cdh', u'spark'], [u'spark-plugin']
[24/Feb/2018 20:38:37 +0000] 9061 MainThread parcel INFO No parcels activated for use
[24/Feb/2018 20:38:37 +0000] 9061 MainThread __init__ INFO Extracted 23 files and 0 dirs to /var/run/cloudera-scm-agent/process/ccdeploy_spark-conf_etcsparkconf.cloudera.spark_on_yarn_8051333488325061867.

 

 

 

Any help will be greatly appreicated. 

 

 

Thanks,

Ben 

2 REPLIES 2

Expert Contributor

This is probably because of your sudo configuration.

Edit sudo (visudo) and check if you have the following line. If yes, just comment it out:

Defaults requiretty

Expert Contributor

By the way. CDH 5.19???