Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Every time I run cbd command I get "* Dependency required, installing sed latest ..." as response in CLI

Re: Every time I run cbd command I get "* Dependency required, installing sed latest ..." as response in CLI

@Asvin Kumar

You should try issuing the command with Trace:

TRACE=1 cbd --help

This way you can troubleshoot what exactly is failing.

In the meantime I recommend you to use the latest CBD deployer version of 2.7.1.

Hope this helps!

Highlighted

Re: Every time I run cbd command I get "* Dependency required, installing sed latest ..." as response in CLI

New Contributor

Thanks for the reply @pdarvas.

I can't see the trace after,

++ export 'NON_PROXY_HOSTS=*.consul' ++ NON_PROXY_HOSTS='*.consul' ++ _env+=($var) ++ [[ -n '' ]] ++ [[ -n '' ]] ++ [[ -n '' ]] ++ [[ -n '' ]] ++ curl --connect-timeout 20 -s https://raw.githubusercontent.com/hortonworks/glidergun-rack/master/index/sed + index=

But I can run the curl --connect-timeout 20 -s https://raw.githubusercontent.com/hortonworks/glidergun-rack/master/index/sed + index=

The link http://sequenceiq.com/cloudbreak-docs/latest/operations/#proxy-settings not working anymore. Is there anywhere I can see the entire sequence of the cbd generate, so that I can work on the next

Re: Every time I run cbd command I get "* Dependency required, installing sed latest ..." as response in CLI

Expert Contributor

To configure proxy settings for Cloudbreak Deployer, add the following configs to your Profile:

export http_proxy="http://YOUR_PROXY_ADDRESS:YOUR_PROXY_PORT/"
export https_proxy="http(s)://YOUR_PROXY_ADDRESS:YOUR_PROXY_PORT/"
export CB_HTTP_PROXY="http://YOUR_PROXY_ADDRESS:YOUR_PROXY_PORT/"
export CB_HTTPS_PROXY="http(s)://YOUR_PROXY_ADDRESS:YOUR_PROXY_PORT/"
export CB_JAVA_OPTS="-Dhttp.proxyHost=YOUR_PROXY_ADDRESS -Dhttp.proxyPort=YOUR_PROXY_PORT -Dhttps.proxyHost=YOUR_PROXY_ADDRESS -Dhttps.proxyPort=YOUR_PROXY_PORT -Dhttp.nonProxyHosts=172.17.0.1|*.service.consul|*.node.dc1.consul"