Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Fail to start ResourceManger role

avatar
Rising Star

Hi all, I am installing a new CDP cluster, come across an error when starting the service. Here are the error message

Fail to start Resour.PNG

 

Here are the logs

error message3.PNG

I saw there is error related to OnOutOfMemoryError, don't know if it is related.

 

Please kindly help me out with this issue. Thanks.

3 REPLIES 3

avatar
Master Collaborator

@BrianChan  the part you highlighted is just a command parameter and not an error.

Please check for errors in stdout and resource manager role logs as well. Also it would help if you can share the entire logs including stderr, CM agent and supervisord logs of the node. You will generally find issues at the end of file

If this is a new cluster and you don't have issues with service downtime, I would also suggest to stop all services on the resource manager host and hard restart CM agent on the node. This will clear out any potential issues with supervisord staleness.

 

Hope this helps,
Paras
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

 

avatar
Rising Star

Thank you for your reply @paras.

 

The problem is fixed and it is caused by some conflicts related to Kerberos.

 

I enabled Kerberos for the first time I create the cluster but something went wrong, so I delete the cluster and create a new one.

 

This time, I didn't enable Kerberos. However, maybe some settings previously related to Kerberos already stayed in my machine. Therefore, it causes conflict.

 

May I know how to hard reset for the entire cluster setting and hard reset for a particular service? As I probably will reuse the instance and build a new cluster. Thank you in advance.

avatar
Master Collaborator

@BrianChan glad to know the issue is resolved. We do not recommend to disable kerberos once you have it enabled. The process is a complex one and we recommend to work with our support team if you have an active subscription. Also enabling kerberos for few services enabled is not supported.

At high level, you need to work through https://docs.cloudera.com/cdp-private-cloud-base/7.1.6/security-how-to-guides/topics/cm-security-usi...

There are additional steps to delete znodes for hbase , the znodes for High Availability(HA) must be deleted if more than one JobTracker role is configured, the znodes for High Availability(HA) must be deleted if HDFS HA is enabled.
Also ensure your /etc/krb5.conf remains same across all nodes if you are not managing this from Cloudera Manager.

 

Hope this helps,
Paras
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.