Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Failed to configure urlScheme property for Solr cluster in Zookeeper

avatar
Rising Star

I have set three zookeepers services. they are working fine one leader and two follower. But Solr is not able to start due to some property is not available. where to set this property ?

 

I have done setup using Cloudera director - 2.0, CDH 5.5.2

 

Failed to configure urlScheme property for Solr cluster in Zookeeper

using 5 as CDH_VERSION
Unable to set the cluster property due to following error : Error updating cluster property urlScheme
Error: Unable to set the cluster property in ZK
Failed to configure urlScheme property for Solr cluster in Zookeeper
Tue May 17 06:13:53 EDT 2016

1 ACCEPTED SOLUTION

avatar
Expert Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
9 REPLIES 9

avatar

Have you ever had solr up and running in this cluster?  Do you have any active collections?

 

One thing to try is to perform an "Initialize Solr" action from CM  (from within the solr service), when the solr service is shut down.  If solr has not been initialized in ZK, you could get your observed error.

 

-pd

avatar
Rising Star

 

Setting up cluster first time using lastest director 2.0 and CDH 5.5X.

is  "Initialize Solr" action from CM  is same as start Solr ? I have tried start solr many times. it did not work.

avatar

No, initialize solr usually happens when the service is installed, but it may not have if you installed from director.  It is in the Actions drop down menu, and grayed out when solr is running

avatar
Expert Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Rising Star

works perfectly , thanks 

avatar
Explorer

work perfectly,thank you

avatar
Community Manager

@Fadi , I'm happy to see you resolved your issue. Can you please mark the appropriate reply as the solution?  It will make it easier for others to find the answer in the future.

 



Regards,

Vidya Sargur,
Community Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:

avatar
Explorer

it can be resolve in this way:

in CM, open Solr page, do the 2 actions:

Initialize Solr / Create HDFS Home Dir

avatar
New Contributor

It worked perfect for me. Installing from scratch Cloudera Manager 7.4.4 and CDP 7.1.7.