Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Failing deploy cluster ambari

Highlighted

Failing deploy cluster ambari

New Contributor

system details: ubuntu 16.04,

ansible 2.2.0.0

vagrant: 1.9.1 vm: 5.0

java 1.8.0_111

maven 3.3.9

error:

TASK [ambari_config : Deploy cluster with Ambari; http://node1:8080] *********** fatal: [node1]: FAILED! => {"changed": false, "failed": true, "msg": "value of wait_for_complete must be one of: y,yes,on,1,true,1,True,n,no,off,0,false,0,False, got: True"} to retry, use: --limit @/home/rendev/Downloads/incubator-metron-Metron_0.2.1BETA_rc2/metron-deployment/playbooks/metron_full_install.retry

PLAY RECAP ********************************************************************* node1 : ok=31 changed=23 unreachable=0 failed=1

Ansible failed to complete successfully. Any error output should be visible above. Please fix these errors and try again.

can somone help me out here? thanks

12 REPLIES 12

Re: Failing deploy cluster ambari

Super Collaborator

Hey @Umesh Kaushik, metron installation requires ansible version to be 2.0.0.2 specifically.

Please install the pre-requisites as per the requirements at:

https://github.com/apache/incubator-metron/tree/master/metron-deployment/vagrant/quick-dev-platform#...

Re: Failing deploy cluster ambari

New Contributor

@asubramanian , hey thanks for your reply. At the initial stage, I have same requirements and I figured out that vagrant 1.8.1 and 1.8.5 have errors regarding downloading plugins and ssh authentication respectively. However, I tried again with the versions mentioned on the git hub.

I started a built and got the following error on metron:

[ERROR] Failed to execute goal on project metron-parsers: Could not resolve dependencies for project org.apache.metron:metron-parsers:jar:0.3.0: Could not transfer artifact io.thekraken:grok:jar:0.1.0 from/to multiline-release-repo (https://raw.github.com/benelog/multiline/master/maven-repository Connection timed out (Read failed) -> [Help 1] [ERROR] [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch. [ERROR] Re-run Maven using the -X switch to enable full debug logging. [ERROR] [ERROR] For more information about the errors and possible solutions, please read the following articles: [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException [ERROR] [ERROR] After correcting the problems, you can resume the build with the command [ERROR] mvn <goals> -rf :metron-parsers

could you please help me out here:

I tried following options to rectify this:

mvn https://raw.github.com/benelog/multiline/master/maven-repository -rf :metron-parsers

mvn https://raw.github.com/benelog/multiline/master/maven-repository/io.thekraken:grok:jar:0.1.0 -rf :metron-parsers

none of above worked(syntax or method could be wrong if you could help in sorting it out)

following is the error screen:

11308-error-screen.png

along with that I noticed one more thing todo list in the following link

https://github.com/apache/incubator-metron/tree/master/metron-deployment

could it be the reason for this?

Thanks for your time.

Re: Failing deploy cluster ambari

Super Collaborator

@Umesh Kaushik, can you confirm that you are using ansible version 2.0.0.2 (and _not_ 2.2.0.0)?

Re: Failing deploy cluster ambari

New Contributor

Hi, @asubramanian,

yes I am using 2.0.0.2

11323-ansible-ver.png

I was building 0.2 rc1 version and it is failing here

11324-assembly-error.png

however, I was running another built too with package https://github.com/apache/incubator-metron and it got success(after multiple tries). then I got vagrant plugin error

*rendev@BhujangRnD:~/Downloads/incubator-metron/metron-deployment/vagrant$ vagrant plugin install vagrant-hostmanager Installing the 'vagrant-hostmanager' plugin. This can take a few minutes... /usr/lib/ruby/2.3.0/rubygems/specification.rb:946:in `all=': undefined method `group_by' for nil:NilClass (NoMethodError) from /usr/lib/ruby/vendor_ruby/vagrant/bundler.rb:275:in `with_isolated_gem' from /usr/lib/ruby/vendor_ruby/vagrant/bundler.rb:231:in `internal_install' from /usr/lib/ruby/vendor_ruby/vagrant/bundler.rb:102:in `install' from /usr/lib/ruby/vendor_ruby/vagrant/plugin/manager.rb:62:in `block in install_plugin' from /usr/lib/ruby/vendor_ruby/vagrant/plugin/manager.rb:72:in `install_plugin' from /usr/share/vagrant/plugins/commands/plugin/action/install_gem.rb:37:in `call' from /usr/lib/ruby/vendor_ruby/vagrant/action/warden.rb:34:in `call' from /usr/lib/ruby/vendor_ruby/vagrant/action/builder.rb:116:in `call' from /usr/lib/ruby/vendor_ruby/vagrant/action/runner.rb:66:in `block in run' from /usr/lib/ruby/vendor_ruby/vagrant/util/busy.rb:19:in `busy' from /usr/lib/ruby/vendor_ruby/vagrant/action/runner.rb:66:in `run' from /usr/share/vagrant/plugins/commands/plugin/command/base.rb:14:in `action' from /usr/share/vagrant/plugins/commands/plugin/command/install.rb:32:in `block in execute' from /usr/share/vagrant/plugins/commands/plugin/command/install.rb:31:in `each' from /usr/share/vagrant/plugins/commands/plugin/command/install.rb:31:in `execute' from /usr/share/vagrant/plugins/commands/plugin/command/root.rb:56:in `execute' from /usr/lib/ruby/vendor_ruby/vagrant/cli.rb:42:in `execute' from /usr/lib/ruby/vendor_ruby/vagrant/environment.rb:268:in `cli' from /usr/bin/vagrant:173:in `<main>'*

this is because of 1.8.1 vagrant so i am running with 1.9.1. Now here I read *playbooks currently only target RHEL/CentOS 6.x operating systems* and I am using ubuntu 16.04. Could OS be the issue? Shall I try on centOS?

Thanks!

Re: Failing deploy cluster ambari

Super Collaborator

Hi @Umesh Kaushik, in the past I have been able to get an older version of metron working on Ubuntu 14.04, with the pre-requisite versions. However, I have not tried with Ubuntu recently. So, some of the failures that you are seeing could possibly be limitations, since Ubuntu is yet to be supported as per this link.

Yes, it would be good to try on CentOS (7.x if you can) and see if you are able to get it working. Also please try with the latest Metron bits since a lot has changes between 0.2.x and 0.3.x versions.

Re: Failing deploy cluster ambari

Super Collaborator

@Umesh Kaushik, here is the link to the steps that I had followed earlier for Ubuntu 14.04. Please check if this helps.

https://community.hortonworks.com/answers/52493/view.html

Re: Failing deploy cluster ambari

New Contributor

@asubramania, Hi I was able to get it almost done on ubuntu, but it is failing in sanity check,

11327-sanity-check.png

any suggestions would be helpful. thanks !

Re: Failing deploy cluster ambari

New Contributor

hi @asubramanian I was able to run metron but unable to connect to node1:2812 any suggestions?

11329-sanity-passed.png

but I am unbale to connect to node1:2812

it shows unable to connect, any ideas? is it because two services are pointing to it? like sensor status and topology status? this one last thing if you can help with

Re: Failing deploy cluster ambari

Super Collaborator

Hi @Umesh Kaushik, that is great! Was this with CentOS or with Ubuntu?

Okay, can you launch the Ambari UI from http://node1:8080? If yes, then please check the status of the different services. You can navigate to Storm. Under "Quick Links" navigate to Storm UI to check the status of the different topologies.

Also, are you having enough CPU/memory resources on the box where you are attempting to build metron? You can do a vagrant ssh from the incubator-metron/metron-deployment/vagrant/quick-dev-platform directory to get into the box and then check on the different process status.

Don't have an account?
Coming from Hortonworks? Activate your account here