Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Failing to add hosts using ambari UI

Highlighted

Failing to add hosts using ambari UI

New Contributor

I'm trying to add worker nodes in my hortonworks sandbox using add hosts. I'm getting this error. I've tried all the possibilities and i'm trying to follow steps from the hortonworks partner courses and here is the link: http://partner.hortonworks.com/hdp-operations-hadoop-administration-1-spll/75739

adding-workernodes.jpg

logs show this

========================== Creating target directory... ========================== Command start time 2017-11-18 19:09:49 Connection to node2 closed. SSH command execution finished host=node2, exitcode=0 Command end time 2017-11-18 19:09:49 ========================== Copying common functions script... ========================== Command start time 2017-11-18 19:09:49 scp /usr/lib/python2.6/site-packages/ambari_commons host=node2, exitcode=0 Command end time 2017-11-18 19:09:49 ========================== Copying OS type check script... ========================== Command start time 2017-11-18 19:09:49 scp /usr/lib/python2.6/site-packages/ambari_server/os_check_type.py host=node2, exitcode=0 Command end time 2017-11-18 19:09:50 ========================== Running OS type check... ========================== Command start time 2017-11-18 19:09:50 Cluster primary/cluster OS family is redhat6 and local/current OS family is redhat6 Connection to node2 closed. SSH command execution finished host=node2, exitcode=0 Command end time 2017-11-18 19:09:50 ========================== Checking 'sudo' package on remote host... ========================== Command start time 2017-11-18 19:09:50 sudo-1.8.6p3-15.el6.x86_64 Connection to node2 closed. SSH command execution finished host=node2, exitcode=0 Command end time 2017-11-18 19:09:50 ========================== Copying repo file to 'tmp' folder... ========================== Command start time 2017-11-18 19:09:50 scp /etc/yum.repos.d/ambari.repo host=node2, exitcode=0 Command end time 2017-11-18 19:09:50 ========================== Moving file to repo dir... ========================== Command start time 2017-11-18 19:09:50 Connection to node2 closed. SSH command execution finished host=node2, exitcode=0 Command end time 2017-11-18 19:09:51 ========================== Changing permissions for ambari.repo... ========================== Command start time 2017-11-18 19:09:51 Connection to node2 closed. SSH command execution finished host=node2, exitcode=0 Command end time 2017-11-18 19:09:51 ========================== Copying setup script file... ========================== Command start time 2017-11-18 19:09:51 scp /usr/lib/python2.6/site-packages/ambari_server/setupAgent.py host=node2, exitcode=0 Command end time 2017-11-18 19:09:51 ========================== Running setup agent script... ========================== Command start time 2017-11-18 19:09:51 http://node1/hdp/Updates-ambari-2.1.1/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host" Trying other mirror. Error: Cannot retrieve repository metadata (repomd.xml) for repository: Updates-ambari-1.7.0. Please verify its path and try again http://node1/hdp/Updates-ambari-2.1.1/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host" Trying other mirror. Error: Cannot retrieve repository metadata (repomd.xml) for repository: Updates-ambari-1.7.0. Please verify its path and try again ('', None) Connection to node2 closed. SSH command execution finished host=node2, exitcode=1 Command end time 2017-11-18 19:09:52 ERROR: Bootstrap of host node2 fails because previous action finished with non-zero exit code (1) ERROR MESSAGE: tcgetattr: Inappropriate ioctl for device Connection to node2 closed. STDOUT: http://node1/hdp/Updates-ambari-2.1.1/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host" Trying other mirror. Error: Cannot retrieve repository metadata (repomd.xml) for repository: Updates-ambari-1.7.0. Please verify its path and try again http://node1/hdp/Updates-ambari-2.1.1/repodata/repomd.xml: [Errno 14] PYCURL ERROR 7 - "couldn't connect to host" Trying other mirror. Error: Cannot retrieve repository metadata (repomd.xml) for repository: Updates-ambari-1.7.0. Please verify its path and try again ('', None) Connection to node2 closed.

4 REPLIES 4

Re: Failing to add hosts using ambari UI

Contributor

Is your httpd server is up and running? Check restarting your apache webserver and then accessing the repositories.

Also, It seems like you have downloaded the repo and packages to your local server and then installing it. so for that path of repo will be

file:///xyz/zba

which is similar to what you will see in your hdp.rpo or ambari.repo

In case if you are pulling it from Hortonworks server then check for iptables wheather you have disabled them or not. Also, check you can ping to open network from all nodes.

Re: Failing to add hosts using ambari UI

Super Mentor

@sk kumar

Based on the error it looks like your Offline Local repo has some issues Or it is not correctly configured. We see the following 3 errors which looks inter linked.

ERROR-1. Following error indicates that either your WebServer where you have configured the local repo is not running "http://node1" Or there is some host resolution issue from host machines to the node1.

ERROR 7 - "couldn't connect to host" Trying other mirror.

>>> So please check if from ambari server host and the ambari agent hosts you are able to access the node1?

# nc -v node1 80
(OR)
# telnet node1 80 

.

ERROR-2. We see multiple repositories are enabled for ambari 1.7.0 & 2.1.1, Ideally we should see only one there.

http://node1/hdp/Updates-ambari-2.1.1/repodata/repomd.xml
Error: Cannot retrieve repository metadata (repomd.xml) for repository: Updates-ambari-1.7.0

>>> Please check the "/etc/yum.repos.d/ambari.repo file to see if by mistake you have enabled multiple ambari repositories?

Please share all the ambari repository file details from the following path:

# cat /etc/yum.repos.d/ambari.repo
# cat /etc/yum.repos.d/ambari*

.

ERROR-3. Can you please check if your Local Repository webserver is able to server the following URL? You can either try to check the mentioned PATH "/var/www/html/hdp/Updates-ambari-2.1.1/repodata/repomd.xml" exist in your local repo server? Or can you open the mentioned URL from any ambari server/agent host or using browser?

# wget http://node1/hdp/Updates-ambari-2.1.1/repodata/repomd.xml

>>> If above is not working then either the path is incorrect "baseurl" inside your "/etc/yum.repos.d/ambari.repo" or the local repo is not configured properly.

.

Re: Failing to add hosts using ambari UI

Mentor

@sk kumar


Here is the HCC solution to your issue

https://community.hortonworks.com/questions/21075/hdp-23-sandbox-adding-nodes-fails.html#

Please let me know if that helped, meanwhile I will download and try the same process..

Re: Failing to add hosts using ambari UI

Hdp sandbox is a single node env. If you want to play w a virtual cluster try https://community.hortonworks.com/repos/16744/dockerdoop.html

Don't have an account?
Coming from Hortonworks? Activate your account here