Support Questions
Find answers, ask questions, and share your expertise

Failing upgrade: Parameter original_stack has invalid value: HDP-2.4. The cluster is currently on stack HDP-2.5

Explorer

I've already upgraded from HDP-2.4 to HDP-2.5, but for some reason there is another upgrade process "stuck".

Since the cluster is already on HDP-2.5, it fails with the following error message:

Params: Data_PROD HDP-2.4 HDP-2.5 2.5.3.0-37 upgrade nonrolling-upgrade-2.5
Checking if can update the Desired Stack Id to HDP-2.5. The cluster's current Stack Id is HDP-2.5
Parameter original_stack has invalid value: HDP-2.4. The cluster is currently on stack HDP-2.5, HDP-2.5, yet the parameter to this function indicates a different value.

So how do I resolve this?

  • How do I cancel this upgrade?
  • or mark it as completed in the database?
  • Or change the params from HDP-2.4 to HDP-2.5 and let it continue?

Since it's in this state of Upgrade, it doesn't allow me to install new services/clients.

Related to : https://community.hortonworks.com/questions/84554/ambari-242-trying-to-upgrade-hdp-353-to-same-versi...

1 ACCEPTED SOLUTION

Accepted Solutions

Explorer

Resolved. Cleaned up the database references to that upgrade. (did a backup before)

View solution in original post

3 REPLIES 3

@Marco Silva

Can you pass me output of below command -

Login to ambari DB and execute -

ambari=> select * from clusters ;

Explorer

@Sagar Shimpi

clusters:

13277-screen-shot-2017-03-06-at-132606.png

Stack.

13278-screen-shot-2017-03-06-at-132624.png

Explorer

Resolved. Cleaned up the database references to that upgrade. (did a backup before)

View solution in original post