Support Questions
Find answers, ask questions, and share your expertise

Falcon cluster onboarding & oozie URLs

Highlighted

Falcon cluster onboarding & oozie URLs

Contributor

I'm trying to onboard a cluster entity to Falcon. I've successfully followed the tutorials for doing clusters/feeds/process in the sandbox. But for some reason not in our HA environment.

falcon-cluster.xml

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<cluster name="primaryCluster" description="this is primary cluster" colo="primaryColo" xmlns="uri:falcon:cluster:0.1">
    <tags>primaryKey=primaryCluster</tags>
    <interfaces>
        <interface type="readonly" endpoint="hdfs://ip-xx-xx-xx-xx.ec2.internal:50070" version="2.2.0"/>
        <interface type="write" endpoint="hdfs://ip-xx-xx-xx-xx.ec2.internal:8020" version="2.2.0"/>
        <interface type="execute" endpoint="ip-xx-xx-xx-xx.ec2.internal:8050" version="2.2.0"/>
        <interface type="workflow" endpoint="http://oozie.hdp.server:11000/oozie" version="4.0.0"/>
        <interface type="messaging" endpoint="tcp://ip-xx-xx-xx-xx.ec2.internal:61616?daemon=true" version="5.1.6"/>
    </interfaces>
    <locations>
        <location name="staging" path="/apps/falcon/primaryCluster/staging"/>
        <location name="temp" path="/tmp"/>
        <location name="working" path="/apps/falcon/primaryCluster/working"/>
    </locations>
    <ACL owner="ambari-qa" group="users" permission="755"/>
    <properties>
        <property name="dfs.namenode.kerberos.principal" value="nn/_HOST@HDP.FOO.LOCAL"/>
    </properties>
</cluster>

error:

ERROR: Bad Request;default/org.apache.falcon.FalconWebException::org.apache.falcon.FalconException: Invalid Workflow server or port: http://oozie.hdp.server:11000/oozie

cause:

Caused by: E1400 : User [falcon/ip-xx-xx-xx-xx.ec2.internal@HDP.FOO.LOCAL] not defined as proxyuser

new to falcon. any suggestions?

4 REPLIES 4
Highlighted

Re: Falcon cluster onboarding & oozie URLs

New Contributor

@Sonny Heer,

You have to set up proxy user settings for Falcon. See step four of this documentation. You should do this via Ambari on the Oozie config page.

Add the following properties to the /etc/oozie/conf/oozie-site.xml file:

<property>
     <name>oozie.service.ProxyUserService.proxyuser.falcon.hosts</name>
     <value>*</value>
</property>
 
<property>
     <name>oozie.service.ProxyUserService.proxyuser.falcon.groups</name> 
     <value>*</value>
</property>

Highlighted

Re: Falcon cluster onboarding & oozie URLs

Contributor

Thanks for the reply. I do have those properties set in oozie-site already.

Re: Falcon cluster onboarding & oozie URLs

Contributor

Add below properties in core-site.xml using Ambari if you are not using ambari then edit core-site.xml with below values.

<property>

<name>hadoop.proxyuser.oozie.hosts</name>

<value>*</value>

</property>

<property>

<name>hadoop.proxyuser.oozie.groups</name>

<value>*</value>

</property>

<property>

<name>hadoop.proxyuser.falcon.hosts</name>

<value>*</value>

</property>

<property>

<name>hadoop.proxyuser.falcon.groups</name>

<value>*</value>

</property>

Please accept this if it answers your question

Highlighted

Re: Falcon cluster onboarding & oozie URLs

Contributor

Yep, already have all those properties